summaryrefslogtreecommitdiffstats
path: root/package/python/python-disable_modules_and_ssl.patch
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-12 00:06:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-12 00:06:48 +0000
commit4e809df67f33170e0b79a88116057b05576a230a (patch)
tree43176b45e94d65d56945e2cba330208ebfd28efa /package/python/python-disable_modules_and_ssl.patch
parent663a55ca28e2de33cd37897e030dcc13d04f079f (diff)
downloadbuildroot-novena-4e809df67f33170e0b79a88116057b05576a230a.tar.gz
buildroot-novena-4e809df67f33170e0b79a88116057b05576a230a.zip
more updates for python
Diffstat (limited to 'package/python/python-disable_modules_and_ssl.patch')
-rw-r--r--package/python/python-disable_modules_and_ssl.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/python/python-disable_modules_and_ssl.patch b/package/python/python-disable_modules_and_ssl.patch
new file mode 100644
index 000000000..073296c5f
--- /dev/null
+++ b/package/python/python-disable_modules_and_ssl.patch
@@ -0,0 +1,36 @@
+--- python.old/setup.py 2003-11-01 19:23:48.495647848 +0000
++++ python/setup.py 2003-11-01 19:24:16.044459792 +0000
+@@ -15,7 +15,14 @@
+ from distutils.command.install_lib import install_lib
+
+ # This global variable is used to hold the list of modules to be disabled.
+-disabled_module_list = []
++try:
++ disabled_module_list = os.environ["PYTHON_DISABLE_MODULES"].split()
++except KeyError:
++ disabled_module_list = []
++try:
++ disable_ssl = os.environ["PYTHON_DISABLE_SSL"]
++except KeyError:
++ disable_ssl = 0
+
+ def add_dir_to_list(dirlist, dir):
+ """Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -240,6 +247,7 @@
+ return sys.platform
+
+ def detect_modules(self):
++ global disable_ssl
+ # Ensure that /usr/local is always used
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+@@ -451,7 +459,8 @@
+ ] )
+
+ if (ssl_incs is not None and
+- ssl_libs is not None):
++ ssl_libs is not None and
++ not disable_ssl):
+ exts.append( Extension('_ssl', ['_ssl.c'],
+ include_dirs = ssl_incs,
+ library_dirs = ssl_libs,