summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-009-python-symlink.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
commit0eef30440e9597b2c0b9c7a0340a3986a7ea2a65 (patch)
treef8e74a929418c8085bc09dd5606a10e356923c74 /package/python/python-2.7-009-python-symlink.patch
parent4c6a451ac9fab16abcda5834ed4a9b728091ab9e (diff)
parent6ea3c8bd4dabe2b11a8beecb6a641336e6e90f3c (diff)
downloadbuildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.tar.gz
buildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.zip
Merge branch 'for-2011.02/python-bump' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/python/python-2.7-009-python-symlink.patch')
-rw-r--r--package/python/python-2.7-009-python-symlink.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/python/python-2.7-009-python-symlink.patch b/package/python/python-2.7-009-python-symlink.patch
new file mode 100644
index 000000000..f284dba55
--- /dev/null
+++ b/package/python/python-2.7-009-python-symlink.patch
@@ -0,0 +1,25 @@
+Use a symlink between python and pythonVERSION
+
+By default, a hard link is used between /usr/bin/python and
+/usr/bin/pythonVERSION. Using hard links for such things is fairly
+uncommon, so let's make a symbolic link instead.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ Makefile.pre.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: Python-2.7.1/Makefile.pre.in
+===================================================================
+--- Python-2.7.1.orig/Makefile.pre.in
++++ Python-2.7.1/Makefile.pre.in
+@@ -791,7 +791,7 @@
+ then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
+ else true; \
+ fi
+- (cd $(DESTDIR)$(BINDIR); $(LN) python$(VERSION)$(EXE) $(PYTHON))
++ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) $(PYTHON))
+ -rm -f $(DESTDIR)$(BINDIR)/python-config
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python-config)
+ -test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)