summaryrefslogtreecommitdiffstats
path: root/package/python/python-010-disable_modules_and_ssl.patch
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-22 18:48:48 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-22 18:48:48 +0000
commit6440b9fd175c06263b5da2616e228e39e424cccd (patch)
tree90b0a40a00529983cf002d6bed4a901674f2ef8e /package/python/python-010-disable_modules_and_ssl.patch
parent92139ef20f9bfbf2e22ee9b6be0f0694fd85b710 (diff)
downloadbuildroot-novena-6440b9fd175c06263b5da2616e228e39e424cccd.tar.gz
buildroot-novena-6440b9fd175c06263b5da2616e228e39e424cccd.zip
- fixup include- and libdirs. Closes #841
- rediff patches against 2.4.2
Diffstat (limited to 'package/python/python-010-disable_modules_and_ssl.patch')
-rw-r--r--package/python/python-010-disable_modules_and_ssl.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/python/python-010-disable_modules_and_ssl.patch b/package/python/python-010-disable_modules_and_ssl.patch
new file mode 100644
index 000000000..c7d41184e
--- /dev/null
+++ b/package/python/python-010-disable_modules_and_ssl.patch
@@ -0,0 +1,37 @@
+diff -rduNp Python-2.4.2-002/setup.py Python-2.4.2/setup.py
+--- Python-2.4.2-002/setup.py 2007-01-22 19:41:47.000000000 +0100
++++ Python-2.4.2/setup.py 2007-01-22 19:47:25.000000000 +0100
+@@ -15,7 +15,14 @@ from distutils.command.install import in
+ from distutils.command.install_lib import install_lib
+
+ # This global variable is used to hold the list of modules to be disabled.
+-disabled_module_list = []
++try:
++ disabled_module_list = os.environ["PYTHON_DISABLE_MODULES"].split()
++except KeyError:
++ disabled_module_list = []
++try:
++ disable_ssl = os.environ["PYTHON_DISABLE_SSL"]
++except KeyError:
++ disable_ssl = 0
+
+ def add_dir_to_list(dirlist, dir):
+ """Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -247,6 +254,7 @@ class PyBuildExt(build_ext):
+ return sys.platform
+
+ def detect_modules(self):
++ global disable_ssl
+ for dir in modules_include_dirs:
+ add_dir_to_list(self.compiler.include_dirs, dir)
+ for dir in modules_lib_dirs:
+@@ -468,7 +476,8 @@ class PyBuildExt(build_ext):
+ ] )
+
+ if (ssl_incs is not None and
+- ssl_libs is not None):
++ ssl_libs is not None and
++ not disable_ssl):
+ exts.append( Extension('_ssl', ['_ssl.c'],
+ include_dirs = ssl_incs,
+ library_dirs = ssl_libs,