summaryrefslogtreecommitdiffstats
path: root/package/python-serial/python-serial.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
commit0eef30440e9597b2c0b9c7a0340a3986a7ea2a65 (patch)
treef8e74a929418c8085bc09dd5606a10e356923c74 /package/python-serial/python-serial.mk
parent4c6a451ac9fab16abcda5834ed4a9b728091ab9e (diff)
parent6ea3c8bd4dabe2b11a8beecb6a641336e6e90f3c (diff)
downloadbuildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.tar.gz
buildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.zip
Merge branch 'for-2011.02/python-bump' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/python-serial/python-serial.mk')
-rw-r--r--package/python-serial/python-serial.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/python-serial/python-serial.mk b/package/python-serial/python-serial.mk
new file mode 100644
index 000000000..048930bae
--- /dev/null
+++ b/package/python-serial/python-serial.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-serial
+#
+#############################################################
+
+PYTHON_SERIAL_VERSION = 2.5
+PYTHON_SERIAL_SOURCE = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
+PYTHON_SERIAL_SITE = http://pypi.python.org/packages/source/p/pyserial/
+
+PYTHON_SERIAL_DEPENDENCIES = python
+
+define PYTHON_SERIAL_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_SERIAL_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS,package,python-serial))