summaryrefslogtreecommitdiffstats
path: root/package/pkgconfig/pkgconfig.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:48:13 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:48:13 +0000
commit4ac03cc86a989c2f86b2cdb7041b854bf9609049 (patch)
treeed1fe069c952e2aac6f037bf880734fab7fe60e3 /package/pkgconfig/pkgconfig.mk
parentceb285976563f6ba2c87a17ff92f1b1490df698a (diff)
downloadbuildroot-novena-4ac03cc86a989c2f86b2cdb7041b854bf9609049.tar.gz
buildroot-novena-4ac03cc86a989c2f86b2cdb7041b854bf9609049.zip
filter pkgconfig output to force it do use our staging_dir and not
try to use the system libraries as it is inclined to do
Diffstat (limited to 'package/pkgconfig/pkgconfig.mk')
-rw-r--r--package/pkgconfig/pkgconfig.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pkgconfig/pkgconfig.mk b/package/pkgconfig/pkgconfig.mk
index 682241a7e..c86f78e54 100644
--- a/package/pkgconfig/pkgconfig.mk
+++ b/package/pkgconfig/pkgconfig.mk
@@ -28,6 +28,7 @@ $(PKGCONFIG_DIR)/.configured: $(PKGCONFIG_DIR)/.unpacked
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
@@ -45,6 +46,9 @@ $(PKGCONFIG_DIR)/$(PKGCONFIG_BINARY): $(PKGCONFIG_DIR)/.configured
$(STAGING_DIR)/$(PKGCONFIG_TARGET_BINARY): $(PKGCONFIG_DIR)/$(PKGCONFIG_BINARY)
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(PKGCONFIG_DIR) install
+ mv $(STAGING_DIR)/usr/bin/pkg-config $(STAGING_DIR)/usr/bin/pkg-config.real
+ cp package/pkgconfig/pkgconfig-filter.sh $(STAGING_DIR)/usr/bin/pkg-config
+ mkdir -p $(STAGING_DIR)/lib/pkgconfig
rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \
$(STAGING_DIR)/usr/man $(STAGING_DIR)/usr/share/doc