summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2012-11-03 06:52:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-04 13:33:29 +0100
commitdb961da67fcb59f4bb636150256ad05a0c6fbf2f (patch)
tree5f359647edda2e9fa0327699eb88e46a4cf983c2 /package/pkg-generic.mk
parent19b18527d763e7ef19dec1ca749fdc43729bbfc0 (diff)
downloadbuildroot-novena-db961da67fcb59f4bb636150256ad05a0c6fbf2f.tar.gz
buildroot-novena-db961da67fcb59f4bb636150256ad05a0c6fbf2f.zip
legal-info: support per-package hooks
Useful to produce extra warnings for packages that have special licensing-related issues. Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 270da60c6..9c87aecba 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -316,6 +316,7 @@ $(2)_POST_INSTALL_HOOKS ?=
$(2)_POST_INSTALL_STAGING_HOOKS ?=
$(2)_POST_INSTALL_TARGET_HOOKS ?=
$(2)_POST_INSTALL_IMAGES_HOOKS ?=
+$(2)_POST_LEGAL_INFO_HOOKS ?=
# human-friendly targets and target sequencing
$(1): $(1)-install
@@ -488,6 +489,7 @@ endif
endif
@$(call legal-manifest,$$($(2)_RAWNAME),$$($(2)_VERSION),$$($(2)_LICENSE),$$($(2)_MANIFEST_LICENSE_FILES),$$($(2)_MANIFEST_TARBALL))
endif # ifneq ($(call qstrip,$$($(2)_SOURCE)),)
+ $(foreach hook,$($(2)_POST_LEGAL_INFO_HOOKS),$(call $(hook))$(sep))
# add package to the general list of targets if requested by the buildroot
# configuration