summaryrefslogtreecommitdiffstats
path: root/package/openvpn/openvpn.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-15 06:26:06 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-15 21:23:28 +0100
commit763ad50bd72dead80d2a50c637291f06da8caaaf (patch)
tree82b352a635533f9ead4d9b7012127b4e8c57952b /package/openvpn/openvpn.mk
parent32ab8f21e6877e47c246896c6fb962861b42717d (diff)
downloadbuildroot-novena-763ad50bd72dead80d2a50c637291f06da8caaaf.tar.gz
buildroot-novena-763ad50bd72dead80d2a50c637291f06da8caaaf.zip
openvpn: bump to version 2.3.0
Toolchain IPv6 support isn't optional any more. New PolarSSL backend besides the usual OpenSSL one. New small binary option, reduces binary file size ~100 KiB depending on target architecture. Removed no crypto option - it still requires some SSL library headers and it's pointless anyway, after all we're talking about a VPN solution here. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openvpn/openvpn.mk')
-rw-r--r--package/openvpn/openvpn.mk32
1 files changed, 21 insertions, 11 deletions
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 1c6e6ecdf..2658d76a9 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -4,17 +4,23 @@
#
#############################################################
-OPENVPN_VERSION = 2.2.2
+OPENVPN_VERSION = 2.3.0
OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small --disable-plugins \
- --with-ifconfig-path=/sbin/ifconfig \
- --with-route-path=/sbin/route \
- --with-netstat-path=/bin/netstat
+OPENVPN_DEPENDENCIES = host-pkgconf
+OPENVPN_CONF_OPT = --disable-plugin-auth-pam --enable-iproute2
+OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
+ NETSTAT=/bin/netstat \
+ ROUTE=/sbin/route
+
+ifeq ($(BR2_PACKAGE_OPENVPN_SMALL),y)
+OPENVPN_CONF_OPT += --enable-small --disable-plugins \
+ --disable-debug --disable-eurephia
+endif
ifeq ($(BR2_PACKAGE_IPROUTE2),y)
-OPENVPN_CONF_OPT += --with-iproute-path=/sbin/ip
+OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
else
-OPENVPN_CONF_OPT += --with-iproute-path=/bin/ip
+OPENVPN_CONF_ENV += IPROUTE=/bin/ip
endif
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
@@ -23,14 +29,18 @@ else
OPENVPN_CONF_OPT += --disable-lzo
endif
-ifeq ($(BR2_PACKAGE_OPENVPN_OPENSSL),y)
+ifeq ($(BR2_PACKAGE_OPENVPN_CRYPTO_OPENSSL),y)
+ OPENVPN_CONF_OPT += --with-crypto-library=openssl
OPENVPN_DEPENDENCIES += openssl
-else
- OPENVPN_CONF_OPT += --disable-crypto --disable-ssl
+endif
+
+ifeq ($(BR2_PACKAGE_OPENVPN_CRYPTO_POLARSSL),y)
+ OPENVPN_CONF_OPT += --with-crypto-library=polarssl
+ OPENVPN_DEPENDENCIES += polarssl
endif
define OPENVPN_INSTALL_TARGET_CMDS
- $(INSTALL) -m 755 $(@D)/openvpn \
+ $(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
$(TARGET_DIR)/usr/sbin/openvpn
if [ ! -f $(TARGET_DIR)/etc/init.d/openvpn ]; then \
$(INSTALL) -m 755 -D package/openvpn/openvpn.init \