summaryrefslogtreecommitdiffstats
path: root/package/opengl/libgles
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2013-05-30 14:08:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-30 15:42:45 +0200
commit14470b325935ee8a0ef8b73b33827ab633c1366f (patch)
tree6cc17b1e78f289b2fab92a0da5919ff9f9e65613 /package/opengl/libgles
parent7183fc0f3fefc9722bcd1f1be6ca02cdbfe0eb57 (diff)
downloadbuildroot-novena-14470b325935ee8a0ef8b73b33827ab633c1366f.tar.gz
buildroot-novena-14470b325935ee8a0ef8b73b33827ab633c1366f.zip
opengl: correct detection of virtual packages having no dependencies
I believe the original intent was to make it that the configure step for the opengl virtual packages fails if there is not at least one dependency. This patch fixes the logic so that it actually fails if dependency list is empty Signed-off-by: Will Wagner <will_wagner@carallon.com> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/opengl/libgles')
-rw-r--r--package/opengl/libgles/libgles.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/opengl/libgles/libgles.mk b/package/opengl/libgles/libgles.mk
index f0d0eec9c..675d11fd3 100644
--- a/package/opengl/libgles/libgles.mk
+++ b/package/opengl/libgles/libgles.mk
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
LIBGLES_DEPENDENCIES += rpi-userland
endif
-ifeq ($(LIBGLES_DEPENDENCIES),y)
+ifeq ($(LIBGLES_DEPENDENCIES),)
define LIBGLES_CONFIGURE_CMDS
echo "No libGLES implementation selected. Configuration error."
exit 1