summaryrefslogtreecommitdiffstats
path: root/package/olsr/olsr-configurable-ldconfig.patch
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-29 11:20:04 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-29 22:46:43 +0100
commit9b48690efb592ae17c9dd5a7db7b5ecebed09100 (patch)
tree96994df1d59a5342107cfb632928be22d81cdaae /package/olsr/olsr-configurable-ldconfig.patch
parent3c80d680f2e4d3e568bfeef2c46ceccc952db42d (diff)
downloadbuildroot-novena-9b48690efb592ae17c9dd5a7db7b5ecebed09100.tar.gz
buildroot-novena-9b48690efb592ae17c9dd5a7db7b5ecebed09100.zip
olsr: bump to version 0.6.4
Bump olsrd to version 0.6.4 Fixes: http://autobuild.buildroot.net/results/553c8157cd83ca60475caacc119779c778806781/ which is due to the old version not being friendly with newer flex versions. Enabled more plugins to make it more useful. Switch to forked mode in the init script to avoid console noise. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/olsr/olsr-configurable-ldconfig.patch')
-rw-r--r--package/olsr/olsr-configurable-ldconfig.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/package/olsr/olsr-configurable-ldconfig.patch b/package/olsr/olsr-configurable-ldconfig.patch
index 09e34f137..73fff7eec 100644
--- a/package/olsr/olsr-configurable-ldconfig.patch
+++ b/package/olsr/olsr-configurable-ldconfig.patch
@@ -5,26 +5,29 @@ we make the path to ldconfig configurable through the environment/make
command line. This allows to pass LDCONFIG=/bin/true when doing
cross-compilation.
+[Gustavo: update patch for olsr 0.6.4]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Index: b/make/Makefile.linux
-===================================================================
---- a/make/Makefile.linux
-+++ b/make/Makefile.linux
+diff -Nura olsrd-0.6.4.orig/make/Makefile.linux olsrd-0.6.4/make/Makefile.linux
+--- olsrd-0.6.4.orig/make/Makefile.linux 2013-01-29 09:00:18.041356389 -0300
++++ olsrd-0.6.4/make/Makefile.linux 2013-01-29 09:01:51.598226624 -0300
@@ -3,6 +3,7 @@
#
ARCH := $(shell uname -m)
+LDCONFIG ?= /sbin/ldconfig
- DESTDIR ?=
- LIBDIR = $(DESTDIR)$(shell if [ "$(ARCH)" = "x86_64" -a -d "/usr/lib64" ]; then echo "/usr/lib64"; else echo "/usr/lib"; fi)
-
-@@ -14,7 +15,7 @@
+ DESTDIR ?=
+ prefix ?= /usr/local
+@@ -26,9 +27,9 @@
+ PLUGIN_SONAME ?= lib$(PLUGIN_NAME).so
PLUGIN_FULLNAME ?= $(PLUGIN_NAME).so.$(PLUGIN_VER)
INSTALL_LIB = install -D -m 755 $(PLUGIN_FULLNAME) $(LIBDIR)/$(PLUGIN_FULLNAME); \
- /sbin/ldconfig -n $(LIBDIR)
+ $(LDCONFIG) -n $(LIBDIR)
+ UNINSTALL_LIB = rm -f $(LIBDIR)/$(PLUGIN_FULLNAME); \
+- /sbin/ldconfig -n $(LIBDIR)
++ $(LDCONFIG) -n $(LIBDIR)
ifdef OLSRD_PLUGIN
GENERATE_PIC = true