summaryrefslogtreecommitdiffstats
path: root/package/mpfr
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/mpfr
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/mpfr')
-rw-r--r--package/mpfr/mpfr.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/mpfr/mpfr.mk b/package/mpfr/mpfr.mk
index e3bd3c624..bab52974a 100644
--- a/package/mpfr/mpfr.mk
+++ b/package/mpfr/mpfr.mk
@@ -40,18 +40,19 @@ $(MPFR_DIR)/.configured: $(MPFR_DIR)/.unpacked $(STAGING_DIR)/lib/$(GMP_BINARY)
CFLAGS="$(TARGET_CFLAGS)" \
ac_cv_c_bigendian=$(MPFR_BE) \
./configure \
- --host=$(REAL_GNU_TARGET_NAME) \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --prefix=$(STAGING_DIR) \
- --exec_prefix=$(STAGING_DIR) \
- --libdir=$(STAGING_DIR)/lib \
- --includedir=$(STAGING_DIR)/include \
+ --prefix=/usr \
+ --exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
+ --includedir=/include \
--mandir=/usr/man \
--infodir=/usr/info \
--enable-shared \
@@ -68,7 +69,7 @@ $(STAGING_DIR)/lib/$(MPFR_BINARY): $(MPFR_DIR)/.libs/$(MPFR_BINARY)
exec_prefix=$(STAGING_DIR) \
bindir=$(STAGING_DIR)/bin \
sbindir=$(STAGING_DIR)/sbin \
- libexecdir=$(STAGING_DIR)/libexec \
+ libexecdir=$(STAGING_DIR)/bin \
datadir=$(STAGING_DIR)/share \
sysconfdir=$(STAGING_DIR)/etc \
sharedstatedir=$(STAGING_DIR)/com \
@@ -115,6 +116,7 @@ $(MPFR_DIR2)/.configured: $(MPFR_DIR)/.unpacked $(GMP_HOST_DIR)/lib/$(GMP_BINARY
--includedir=$(STAGING_DIR)/include \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \