summaryrefslogtreecommitdiffstats
path: root/package/memtester/memtester-4.2.1-makefile-fix.patch
diff options
context:
space:
mode:
authorMartin Banky <martin.banky@gmail.com>2010-12-12 22:53:55 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-14 00:35:51 +0100
commit39f7af961aa422c87ccd24be60f3882bb0d9707b (patch)
tree1ee68e28913c41d90dff7b639ff2fbea6a3991b0 /package/memtester/memtester-4.2.1-makefile-fix.patch
parent564e0c7e655f4cbb225427230cf3b22be0575653 (diff)
downloadbuildroot-novena-39f7af961aa422c87ccd24be60f3882bb0d9707b.tar.gz
buildroot-novena-39f7af961aa422c87ccd24be60f3882bb0d9707b.zip
memtester: convert to gentargets and bump to 4.2.1
Also, memtester requires largefile support [ Thomas: add patch to fix memtester's Makefile at installation stage. Bump to 4.2.1. ] Signed-off-by: Martin Banky <Martin.Banky@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/memtester/memtester-4.2.1-makefile-fix.patch')
-rw-r--r--package/memtester/memtester-4.2.1-makefile-fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/memtester/memtester-4.2.1-makefile-fix.patch b/package/memtester/memtester-4.2.1-makefile-fix.patch
new file mode 100644
index 000000000..6f1481bec
--- /dev/null
+++ b/package/memtester/memtester-4.2.1-makefile-fix.patch
@@ -0,0 +1,23 @@
+The a/{b,c} construct doesn't work within make, so let's split the
+creation of the installation directories in two commands.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+Index: memtester-4.2.1/Makefile
+===================================================================
+--- memtester-4.2.1.orig/Makefile
++++ memtester-4.2.1/Makefile
+@@ -25,8 +25,9 @@
+ all: memtester
+
+ install: all
+- mkdir -m 755 -p $(INSTALLPATH)/{bin,man/man8}
++ mkdir -m 755 -p $(INSTALLPATH)/bin
+ install -m 755 memtester $(INSTALLPATH)/bin/
++ mkdir -m 755 -p $(INSTALLPATH)/man/man8
+ gzip -c memtester.8 >memtester.8.gz ; install -m 644 memtester.8.gz $(INSTALLPATH)/man/man8/
+
+ auto-ccld.sh: \