summaryrefslogtreecommitdiffstats
path: root/package/lzo/lzo-2.03-fix-makefile-am.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-12 21:03:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-24 09:30:40 +0200
commit7fe50869fb98d045cca7a21ebb695f17aa2afd1a (patch)
tree1cd87d7afe7de390a6535ab8121b14cd3425e251 /package/lzo/lzo-2.03-fix-makefile-am.patch
parent0ec4298153bd93f8d7efbd1890896fbac5046a7b (diff)
downloadbuildroot-novena-7fe50869fb98d045cca7a21ebb695f17aa2afd1a.tar.gz
buildroot-novena-7fe50869fb98d045cca7a21ebb695f17aa2afd1a.zip
lzo: fix host-lzo build failure when config cache is filled
When the configuration cache has been filled with a value for ac_cv_host, host-lzo fails to detect the target system name. This is due to misbehaving code in the ./configure script. Therefore, we need to autoreconf the package, which in turn requires : * a little fix to the configure.ac file * a little fix to src/Makefile.am * an extraction of important parts of aclocal.m4 into acinclude.m4 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lzo/lzo-2.03-fix-makefile-am.patch')
-rw-r--r--package/lzo/lzo-2.03-fix-makefile-am.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/lzo/lzo-2.03-fix-makefile-am.patch b/package/lzo/lzo-2.03-fix-makefile-am.patch
new file mode 100644
index 000000000..9f23e40db
--- /dev/null
+++ b/package/lzo/lzo-2.03-fix-makefile-am.patch
@@ -0,0 +1,24 @@
+Makefile.am is not allowed to override CFLAGS/CPPFLAGS, it must use
+AM_CFLAGS and AM_CPPFLAGS. This is needed in order for autoreconf to
+work on this package.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ src/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: lzo-2.03/src/Makefile.am
+===================================================================
+--- lzo-2.03.orig/src/Makefile.am
++++ lzo-2.03/src/Makefile.am
+@@ -7,8 +7,8 @@
+ SUFFIXES = .S
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
+-CPPFLAGS = $(LZO_CPPFLAGS) $(configure_CPPFLAGS) $(LZO_EXTRA_CPPFLAGS)
+-CFLAGS = $(LZO_CFLAGS) $(configure_CFLAGS) $(LZO_EXTRA_CFLAGS)
++AM_CPPFLAGS = $(LZO_CPPFLAGS) $(configure_CPPFLAGS) $(LZO_EXTRA_CPPFLAGS)
++AM_CFLAGS = $(LZO_CFLAGS) $(configure_CFLAGS) $(LZO_EXTRA_CFLAGS)
+
+ lib_LTLIBRARIES = liblzo2.la
+