summaryrefslogtreecommitdiffstats
path: root/package/lite/lite.mk
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-26 14:52:17 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-26 14:52:17 +0000
commitc30bb46320213eaa6c95ad991512b03e7fc38c4b (patch)
tree0cef025f5300e42b67838dcff82b7ff63f2e1653 /package/lite/lite.mk
parent6b76f0608a3c46f66b1d223cf4fa75f009e1c41f (diff)
downloadbuildroot-novena-c30bb46320213eaa6c95ad991512b03e7fc38c4b.tar.gz
buildroot-novena-c30bb46320213eaa6c95ad991512b03e7fc38c4b.zip
Adds support for building LiTE - see DirectFB.org
Will close bug 0003974 Daniel Laird
Diffstat (limited to 'package/lite/lite.mk')
-rw-r--r--package/lite/lite.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/lite/lite.mk b/package/lite/lite.mk
new file mode 100644
index 000000000..ad1963278
--- /dev/null
+++ b/package/lite/lite.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# LiTE
+#
+#############################################################
+LITE_VERSION:=0.8.9
+LITE_SOURCE:=LiTE-$(LITE_VERSION).tar.gz
+LITE_SITE:=http://www.directfb.org/downloads/Libs
+LITE_AUTORECONF = NO
+LITE_INSTALL_STAGING = YES
+LITE_INSTALL_TARGET = YES
+LITE_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install
+LITE_CONF_ENV = DFB_CFLAGS=-I$(STAGING_DIR)/usr/include/directfb
+LITE_CONF_OPT =
+LITE_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,lite))
+
+$(LITE_HOOK_POST_INSTALL):
+ $(INSTALL) -d $(TARGET_DIR)/usr/share/LiTE/examples/
+ $(INSTALL) -d $(TARGET_DIR)/usr/share/fonts/truetype
+ $(INSTALL) -m0644 $(LITE_DIR)/data/*.png $(TARGET_DIR)/usr/share/LiTE/
+ $(INSTALL) -m0644 $(LITE_DIR)/examples/*.png $(TARGET_DIR)/usr/share/LiTE/examples/
+ $(INSTALL) -m0644 $(LITE_DIR)/fonts/*.ttf $(TARGET_DIR)/usr/share/fonts/truetype/
+ touch $@ \ No newline at end of file