summaryrefslogtreecommitdiffstats
path: root/package/libgtk2/libgtk2.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-23 22:26:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 12:44:50 +0100
commitdd1848bc73ee9dfe211ca3ed3a233707e3bc5955 (patch)
treed7826f67ccb975f76692dd581770a84d59390259 /package/libgtk2/libgtk2.mk
parenta452db1d822e88f0fe00bf6e65d5979a2f221d72 (diff)
downloadbuildroot-novena-dd1848bc73ee9dfe211ca3ed3a233707e3bc5955.tar.gz
buildroot-novena-dd1848bc73ee9dfe211ca3ed3a233707e3bc5955.zip
libgtk2: use non-host specific patch
The libgtk2 package was using a host-<foo>.patch that should be applied only on the host variant of the package. Unfortunately, with the patch model rework, this doesn't work anymore: Buildroot tries to apply the patch twice, for some reason. But instead of fixing the patch model, it is probably a lot better to fix this patch itself, which is the only usage of host-only patch in Buildroot. So instead of simply removing code that detects dependencies in gtk2's configure.in script, we use a condition based on the value of gdktarget. And it turns out that it makes the patch shorter. However, it requires autoreconfiguring the libgtk2 target package, because we are now modifying its configure.in. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libgtk2/libgtk2.mk')
-rw-r--r--package/libgtk2/libgtk2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index e6a9d84c0..b1ce99ae1 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -12,6 +12,8 @@ LIBGTK2_SITE = http://ftp.gnome.org/pub/gnome/sources/gtk+/$(LIBGTK2_VERSION_MAJ
LIBGTK2_INSTALL_STAGING = YES
LIBGTK2_INSTALL_TARGET = YES
+LIBGTK2_AUTORECONF = YES
+
LIBGTK2_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
glib_cv_uscore=no \
ac_cv_func_strtod=yes \