summaryrefslogtreecommitdiffstats
path: root/package/json-c/json-c-no-reentrant.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-09 07:14:24 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-10 20:41:39 +0200
commitecd0f65af92c224d9d17450ffdef00bd929bcfdf (patch)
treed8ef7fa0aec061b10a44c636053f2c5c9e8f8ee9 /package/json-c/json-c-no-reentrant.patch
parentee377acd8713330e54ef62babbc0b4a5c040446a (diff)
downloadbuildroot-novena-ecd0f65af92c224d9d17450ffdef00bd929bcfdf.tar.gz
buildroot-novena-ecd0f65af92c224d9d17450ffdef00bd929bcfdf.zip
json-c: bump to version 0.11
Bumping this package is needed, because json-c 0.10 has a major defect: it installs a library named libjson.so, which conflicts with the library installed by the libjson package. This has been changed in the upstream json-c 0.11 version, which now installs libjson-c and json-c.pc. It allows to solve the Pulseaudio link problem, which wants to link against json-c but happens to link against libjson when libjson has been compiled and installed after json-c. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/json-c/json-c-no-reentrant.patch')
-rw-r--r--package/json-c/json-c-no-reentrant.patch25
1 files changed, 19 insertions, 6 deletions
diff --git a/package/json-c/json-c-no-reentrant.patch b/package/json-c/json-c-no-reentrant.patch
index 31343c0a8..b8ae6bb24 100644
--- a/package/json-c/json-c-no-reentrant.patch
+++ b/package/json-c/json-c-no-reentrant.patch
@@ -13,19 +13,32 @@ Index: b/Makefile.am.inc
--- a/Makefile.am.inc
+++ b/Makefile.am.inc
@@ -1,2 +1,2 @@
--AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
-+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
+-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
Index: b/Makefile.in
===================================================================
--- a/Makefile.in
+++ b/Makefile.in
-@@ -263,7 +263,7 @@
+@@ -274,7 +274,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
--AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
-+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
+-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
SUBDIRS = . tests
- lib_LTLIBRARIES = libjson.la
+ lib_LTLIBRARIES = libjson-c.la $(am__append_1)
+Index: b/tests/Makefile.in
+===================================================================
+--- a/tests/Makefile.in
++++ b/tests/Makefile.in
+@@ -228,7 +228,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
+ LIBJSON_LA = $(top_builddir)/libjson-c.la
+ test1_LDADD = $(LIBJSON_LA)
+ test1Formatted_LDADD = $(LIBJSON_LA)