summaryrefslogtreecommitdiffstats
path: root/package/iozone/iozone.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-06-14 15:14:46 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-15 21:47:15 +0200
commitf72467e754cc4896adabf07f9e6fabcf10653192 (patch)
tree256626057814eae3514b32a82a80e196b13ba428 /package/iozone/iozone.mk
parent63b4df42f4e6a7965b14595af69f3d1e822d463b (diff)
downloadbuildroot-novena-f72467e754cc4896adabf07f9e6fabcf10653192.tar.gz
buildroot-novena-f72467e754cc4896adabf07f9e6fabcf10653192.zip
iozone: fixup build system
Fixup iozone's build system to make it somewhat more flexible. First make our own linux targets for non-AIO toolchains (uClibc) and non-threading. And second, just ditch forced largefile support and expect it from CFLAGS. Otherwise using the generic target caused issues like: http://autobuild.buildroot.net/results/19f606f2978dc3c8039b1bccfcc562b4050083c7/ ...which is fixed by this. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iozone/iozone.mk')
-rw-r--r--package/iozone/iozone.mk13
1 files changed, 6 insertions, 7 deletions
diff --git a/package/iozone/iozone.mk b/package/iozone/iozone.mk
index eb0a6d89d..970e50982 100644
--- a/package/iozone/iozone.mk
+++ b/package/iozone/iozone.mk
@@ -11,13 +11,12 @@ IOZONE_LICENSE = IOzone license (NO DERIVED WORKS ALLOWED)
# IOzone license details can be found at:
# http://www.iozone.org/docs/Iozone_License.txt
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
-# aio.h is not available on uClibc. Select "generic" target that does not use it.
-IOZONE_TARGET = generic
-else ifeq ($(BR2_powerpc),y)
-IOZONE_TARGET = linux-powerpc
-else ifeq ($(BR2_sparc),y)
-IOZONE_TARGET = linux-sparc
+# No threading target is non-AIO as well
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+IOZONE_TARGET = linux-noth
+# AIO support not available on uClibc, use the linux (non-aio) target.
+else ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
+IOZONE_TARGET = linux-noaio
else
IOZONE_TARGET = linux
endif