summaryrefslogtreecommitdiffstats
path: root/package/icu/icu-both-elif-no-arguments.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-23 23:29:38 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-23 23:32:49 +0200
commitda86b5aceeb2564d10f337e7c7fec01dafa4ad3f (patch)
treec182ab67650862ecf0e011b07486d5cc320a73a6 /package/icu/icu-both-elif-no-arguments.patch
parent6bd9ca56d9f2eba062e09b4650c1d2b66375b199 (diff)
downloadbuildroot-novena-da86b5aceeb2564d10f337e7c7fec01dafa4ad3f.tar.gz
buildroot-novena-da86b5aceeb2564d10f337e7c7fec01dafa4ad3f.zip
icu: fix build with gcc >= 4.4 / JLEVEL > 1
Fix two issues with the icu build: - icu source contains an #elif without any arguments, which g++ >= 4.4 flags as an error. This is both an issue for target and host build, so restructure the .mk so any *both*patch is applied to both builds (the other patches would cause trouble with host builds) - icu build system isn't parallel make safe, use MAKE1 Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/icu/icu-both-elif-no-arguments.patch')
-rw-r--r--package/icu/icu-both-elif-no-arguments.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/icu/icu-both-elif-no-arguments.patch b/package/icu/icu-both-elif-no-arguments.patch
new file mode 100644
index 000000000..8941c53b1
--- /dev/null
+++ b/package/icu/icu-both-elif-no-arguments.patch
@@ -0,0 +1,23 @@
+[PATCH] icu: fix #elif without arguments
+
+ParagraphLayout.cpp contains an #elif without any arguments, which
+g++ >= 4.4 flags as an error. Fix it by replacing it with an #else.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ source/layoutex/ParagraphLayout.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: source/layoutex/ParagraphLayout.cpp
+===================================================================
+--- source.orig/layoutex/ParagraphLayout.cpp
++++ source/layoutex/ParagraphLayout.cpp
+@@ -813,7 +813,7 @@ le_int32 ParagraphLayout::getLanguageCod
+
+ return nullLanguageCode;
+ }
+-#elif
++#else
+
+ // TODO - dummy implementation for right now...
+ le_int32 ParagraphLayout::getLanguageCode(const Locale *locale)