summaryrefslogtreecommitdiffstats
path: root/package/git
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
commit1ba51d2fbddd5650f8caea0a327b9031238ad843 (patch)
tree05d5df7b487e76597b34cb0b1fc9543525169a62 /package/git
parent0c94aa549cc8cf483bc8c3443a2b1f772d5d180b (diff)
parentfb2f3d58bde6aaac12b62eeb16492c93329b8713 (diff)
downloadbuildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.tar.gz
buildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.zip
Merge branch 'next'
Diffstat (limited to 'package/git')
-rw-r--r--package/git/Config.in11
-rw-r--r--package/git/git.mk63
2 files changed, 74 insertions, 0 deletions
diff --git a/package/git/Config.in b/package/git/Config.in
new file mode 100644
index 000000000..31e5ffe5d
--- /dev/null
+++ b/package/git/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_GIT
+ bool "git"
+ depends on BR2_LARGEFILE
+ help
+ Git is a free and open source distributed version control system
+ designed to handle everything from small to very large projects.
+
+ http://git-scm.com
+
+comment "git requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/git/git.mk b/package/git/git.mk
new file mode 100644
index 000000000..408456bc9
--- /dev/null
+++ b/package/git/git.mk
@@ -0,0 +1,63 @@
+#############################################################
+#
+# git
+#
+#############################################################
+
+GIT_VERSION = 1.8.3
+GIT_SITE = http://git-core.googlecode.com/files/
+GIT_LICENSE = GPLv2 LGPLv2.1+
+GIT_LICENSE_FILES = COPYING LGPL-2.1
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+ GIT_DEPENDENCIES += zlib
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ GIT_DEPENDENCIES += openssl
+ GIT_CONF_OPT += --with-openssl
+else
+ GIT_CONF_OPT += --without-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_PERL),y)
+ GIT_DEPENDENCIES += perl
+ GIT_CONF_OPT += --with-libpcre
+else
+ GIT_CONF_OPT += --without-libpcre
+endif
+
+ifeq ($(BR2_PACKAGE_CURL),y)
+ GIT_DEPENDENCIES += curl
+ GIT_CONF_OPT += --with-curl
+else
+ GIT_CONF_OPT += --without-curl
+endif
+
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+ GIT_DEPENDENCIES += expat
+ GIT_CONF_OPT += --with-expat
+else
+ GIT_CONF_OPT += --without-expat
+endif
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+ GIT_DEPENDENCIES += libiconv
+ GIT_CONF_OPT += --with-iconv=/usr/lib
+else
+ GIT_CONF_OPT += --without-iconv
+endif
+
+ifeq ($(BR2_PACKAGE_TCL),y)
+ GIT_DEPENDENCIES += tcl
+ GIT_CONF_OPT += --with-tcltk
+else
+ GIT_CONF_OPT += --without-tcltk
+endif
+
+# assume yes for these tests, configure will bail out otherwise
+# saying error: cannot run test program while cross compiling
+GIT_CONF_ENV = ac_cv_fread_reads_directories=yes \
+ ac_cv_snprintf_returns_bogus=yes
+
+$(eval $(autotools-package))