summaryrefslogtreecommitdiffstats
path: root/package/gdisk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:45:24 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:06:54 +0100
commit29b83f05274d312a0088dcfdfd52fffb65f64422 (patch)
treed79a24f85922b4484868c5d11edadd6bed51d4ca /package/gdisk
parent7cbb30115b0c0e70e298c4f0c7b048c396db46b0 (diff)
downloadbuildroot-novena-29b83f05274d312a0088dcfdfd52fffb65f64422.tar.gz
buildroot-novena-29b83f05274d312a0088dcfdfd52fffb65f64422.zip
gdisk: rename to gptfdisk
In order to match the new upstream name, rename the gdisk package to gptfdisk. We add the relevant legacy configuration options to ensure a smooth transition for users. [Peter: fixup Config.in indentation] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gdisk')
-rw-r--r--package/gdisk/Config.in36
-rw-r--r--package/gdisk/gdisk-001-no-utf16.patch43
-rw-r--r--package/gdisk/gdisk.mk39
3 files changed, 0 insertions, 118 deletions
diff --git a/package/gdisk/Config.in b/package/gdisk/Config.in
deleted file mode 100644
index 24d305d1f..000000000
--- a/package/gdisk/Config.in
+++ /dev/null
@@ -1,36 +0,0 @@
-config BR2_PACKAGE_GDISK
- bool "gdisk"
- depends on BR2_LARGEFILE
- depends on BR2_INSTALL_LIBSTDCPP
- depends on BR2_USE_WCHAR # util-linux
- help
- GPT fdisk (consisting of the gdisk and sgdisk programs) is a
- text-mode partitioning tool that works on Globally Unique Identifier
- (GUID) Partition Table (GPT) disks, rather than on the more common
- (through 2010) Master Boot Record (MBR) partition tables.
-
- http://www.rodsbooks.com/gdisk/
-
-config BR2_PACKAGE_GDISK_GDISK
- bool "interactive gdisk"
- depends on BR2_PACKAGE_GDISK
- select BR2_PACKAGE_UTIL_LINUX
- select BR2_PACKAGE_UTIL_LINUX_LIBUUID
- help
- Install the interactive GUID partition table (GPT) manipulator
- /usr/sbin/gdisk which is modelled after and quite similar in use
- to the traditional MBR based fdisk tool.
-
-config BR2_PACKAGE_GDISK_SGDISK
- bool "command line sgdisk"
- depends on BR2_PACKAGE_GDISK
- select BR2_PACKAGE_UTIL_LINUX
- select BR2_PACKAGE_UTIL_LINUX_LIBUUID
- select BR2_PACKAGE_POPT
- help
- Install the command-line GUID partition table (GPT) manipulator
- /usr/sbin/sgdisk which is named after the traditional MBR based
- sfdisk tool albeit with an entirely different option syntax.
-
-comment "gdisk requires a toolchain with LARGEFILE/WCHAR/C++ support enabled"
- depends on !(BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)
diff --git a/package/gdisk/gdisk-001-no-utf16.patch b/package/gdisk/gdisk-001-no-utf16.patch
deleted file mode 100644
index 540e74190..000000000
--- a/package/gdisk/gdisk-001-no-utf16.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-[PATCH] Disable UTF16 support
-
-libicu is quite large, and unicode partition names are uncommon.
-
-Signed-off-by: Justin Maggard <jmaggard10@gmail.com>
----
-diff -ur gdisk-0.8.5/Makefile gptfdisk-0.8.5/Makefile
---- gdisk-0.8.5/Makefile 2012-05-30 08:38:43.000000000 -0700
-+++ gptfdisk-0.8.5/Makefile 2012-06-05 11:38:23.710597974 -0700
-@@ -1,8 +1,8 @@
- CC=gcc
- CXX=g++
- CFLAGS+=-D_FILE_OFFSET_BITS=64
--CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -D USE_UTF16
--#CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64
-+#CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -D USE_UTF16
-+CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64
- LDFLAGS+=
- LIB_NAMES=crc32 support guid gptpart mbrpart basicmbr mbr gpt bsd parttypes attributes diskio diskio-unix
- MBR_LIBS=support diskio diskio-unix basicmbr mbrpart
-@@ -14,16 +14,16 @@
- all: cgdisk gdisk sgdisk fixparts
-
- gdisk: $(LIB_OBJS) gdisk.o gpttext.o
--# $(CXX) $(LIB_OBJS) gdisk.o gpttext.o $(LDFLAGS) -luuid -o gdisk
-- $(CXX) $(LIB_OBJS) gdisk.o gpttext.o $(LDFLAGS) -licuio -licuuc -luuid -o gdisk
-+ $(CXX) $(LIB_OBJS) gdisk.o gpttext.o $(LDFLAGS) -luuid -o gdisk
-+# $(CXX) $(LIB_OBJS) gdisk.o gpttext.o $(LDFLAGS) -licuio -licuuc -luuid -o gdisk
-
- cgdisk: $(LIB_OBJS) cgdisk.o gptcurses.o
--# $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o $(LDFLAGS) -luuid -lncurses -o cgdisk
-- $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o $(LDFLAGS) -licuio -licuuc -luuid -lncurses -o cgdisk
-+ $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o $(LDFLAGS) -luuid -lncurses -o cgdisk
-+# $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o $(LDFLAGS) -licuio -licuuc -luuid -lncurses -o cgdisk
-
- sgdisk: $(LIB_OBJS) sgdisk.o gptcl.o
--# $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o $(LDFLAGS) -luuid -lpopt -o sgdisk
-- $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o $(LDFLAGS) -licuio -licuuc -luuid -lpopt -o sgdisk
-+ $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o $(LDFLAGS) -luuid -lpopt -o sgdisk
-+# $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o $(LDFLAGS) -licuio -licuuc -luuid -lpopt -o sgdisk
-
- fixparts: $(MBR_LIB_OBJS) fixparts.o
- $(CXX) $(MBR_LIB_OBJS) fixparts.o $(LDFLAGS) -o fixparts
diff --git a/package/gdisk/gdisk.mk b/package/gdisk/gdisk.mk
deleted file mode 100644
index cda369ede..000000000
--- a/package/gdisk/gdisk.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#############################################################
-#
-# gdisk
-#
-#############################################################
-
-GDISK_VERSION = 0.8.6
-GDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
-GDISK_SOURCE = gptfdisk-$(GDISK_VERSION).tar.gz
-
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_GDISK) += gdisk
-GDISK_TARGETS_$(BR2_PACKAGE_GDISK_SGDISK) += sgdisk
-
-ifneq ($(GDISK_TARGETS_y),)
-
-GDISK_DEPENDENCIES += util-linux
-ifeq ($(BR2_PACKAGE_GDISK_SGDISK),y)
- GDISK_DEPENDENCIES += popt
-endif
-
-
-define GDISK_BUILD_CMDS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" \
- -C $(@D) $(GDISK_TARGETS_y)
-endef
-
-define GDISK_INSTALL_TARGET_CMDS
- for i in $(GDISK_TARGETS_y); do \
- $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
- done
-endef
-
-define GDISK_UNINSTALL_TARGET_CMDS
- rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GDISK_TARGETS_y))
-endef
-
-endif
-
-$(eval $(generic-package))