summaryrefslogtreecommitdiffstats
path: root/package/gd/gd.mk
diff options
context:
space:
mode:
authorJean-Christian de Rivaz <jc@eclis.ch>2013-01-18 04:55:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-18 23:22:27 +0100
commit7b69814d4880c2f58e2aad44f9912468a600708b (patch)
tree1d4413c3ffa6bfcd04acb3df8b6946e05837a43e /package/gd/gd.mk
parenta1b941d789ad1394a4c6b64a5a6872a79350b7ff (diff)
downloadbuildroot-novena-7b69814d4880c2f58e2aad44f9912468a600708b.tar.gz
buildroot-novena-7b69814d4880c2f58e2aad44f9912468a600708b.zip
gd: ensure libpng-config from staging is used
The gd package configure call 'libpng-config' to get the compiler flags required to use the libpng. The configure correctly allow to specify the path of the staging libpng-config by using the ac_cv_path_LIBPNG_CONFIG but the configure.ac call simply 'libpng-config' instead of the specified one. The configure.ac is now modified to call the specified libpng_config. [Peter: explictly pass --without-png instead of auto detect] Signed-off-by: Jean-Christian de Rivaz <jc@eclis.ch> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gd/gd.mk')
-rw-r--r--package/gd/gd.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/gd/gd.mk b/package/gd/gd.mk
index 972d8dda4..de1f5d171 100644
--- a/package/gd/gd.mk
+++ b/package/gd/gd.mk
@@ -33,6 +33,10 @@ endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
GD_DEPENDENCIES += libpng
GD_CONF_OPT += --with-png
+GD_CONF_ENV += ac_cv_path_LIBPNG12_CONFIG=""
+GD_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
+else
+GD_CONF_OPT += --without-png
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXPM),y)