summaryrefslogtreecommitdiffstats
path: root/package/games/rubix/rubix.mk
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
commit1b5c1e7bdbdf496078a8556c2906919432f60d52 (patch)
tree0eb0f404efb85594de1dfb4e3d31856d04808faf /package/games/rubix/rubix.mk
parent022b95d6ef7b303f6fbd48c220001674eec4717a (diff)
downloadbuildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.tar.gz
buildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.zip
games: Move all games into games subdir
Moved all games into a subdir called games and then updated makefiles as necessary. If not one objects to this one then I will probably do the same for audio next. Daniel Laird
Diffstat (limited to 'package/games/rubix/rubix.mk')
-rw-r--r--package/games/rubix/rubix.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/games/rubix/rubix.mk b/package/games/rubix/rubix.mk
new file mode 100644
index 000000000..586f9cf60
--- /dev/null
+++ b/package/games/rubix/rubix.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# rubix
+#
+#############################################################
+RUBIX_VERSION = 1.0.5
+RUBIX_SOURCE = rubix-$(RUBIX_VERSION).tar.bz2
+RUBIX_SITE = http://avr32linux.org/twiki/pub/Main/Rubix
+RUBIX_INSTALL_STAGING = NO
+RUBIX_INSTALL_TARGET = YES
+RUBIX_INSTALL_TARGET_OPT = GAMESDIR=$(TARGET_DIR)/usr/games install
+
+RUBIX_MAKE_OPT = CC=$(TARGET_CC) XINC="-I$(STAGING_DIR)/usr/include/X11" XLIB="-L$(STAGING_DIR)/usr/lib -lX11"
+
+RUBIX_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,rubix))
+