summaryrefslogtreecommitdiffstats
path: root/package/games/gnuchess/gnuchess.mk
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
commit1b5c1e7bdbdf496078a8556c2906919432f60d52 (patch)
tree0eb0f404efb85594de1dfb4e3d31856d04808faf /package/games/gnuchess/gnuchess.mk
parent022b95d6ef7b303f6fbd48c220001674eec4717a (diff)
downloadbuildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.tar.gz
buildroot-novena-1b5c1e7bdbdf496078a8556c2906919432f60d52.zip
games: Move all games into games subdir
Moved all games into a subdir called games and then updated makefiles as necessary. If not one objects to this one then I will probably do the same for audio next. Daniel Laird
Diffstat (limited to 'package/games/gnuchess/gnuchess.mk')
-rw-r--r--package/games/gnuchess/gnuchess.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/games/gnuchess/gnuchess.mk b/package/games/gnuchess/gnuchess.mk
new file mode 100644
index 000000000..b1ff3b73a
--- /dev/null
+++ b/package/games/gnuchess/gnuchess.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# gnuchess
+#
+#############################################################
+GNUCHESS_VERSION = 5.07
+GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
+GNUCHESS_SITE = $(BR2_GNU_MIRROR)/chess
+GNUCHESS_INSTALL_STAGING = NO
+GNUCHESS_INSTALL_TARGET = YES
+
+GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
+
+GNUCHESS_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,gnuchess))
+