summaryrefslogtreecommitdiffstats
path: root/package/fluxbox/fluxbox-1.3.2-fix-configure.patch
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-12-30 11:33:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-03 21:34:56 +0100
commita025fd9b5a43f61f4b7ed051f6dcb422ec18cc83 (patch)
treea7fd9901139307a3ec3b91063308483dd16a3210 /package/fluxbox/fluxbox-1.3.2-fix-configure.patch
parentd946a1af93741a7ae22ec69be865a6c14a37fcf1 (diff)
downloadbuildroot-novena-a025fd9b5a43f61f4b7ed051f6dcb422ec18cc83.tar.gz
buildroot-novena-a025fd9b5a43f61f4b7ed051f6dcb422ec18cc83.zip
fluxbox: fix build against imlib2
* fix configure.in to take care of the given imlib2-prefix * disable imlib2 support if imlib2 is not part of the selection [Peter: imlib2 needs to be built with X support] Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fluxbox/fluxbox-1.3.2-fix-configure.patch')
-rw-r--r--package/fluxbox/fluxbox-1.3.2-fix-configure.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/fluxbox/fluxbox-1.3.2-fix-configure.patch b/package/fluxbox/fluxbox-1.3.2-fix-configure.patch
new file mode 100644
index 000000000..2cb827360
--- /dev/null
+++ b/package/fluxbox/fluxbox-1.3.2-fix-configure.patch
@@ -0,0 +1,19 @@
+Avoid to call the imlib2-config that may be installed on the host system
+(even when --with-imlib2-prefix or --with-imlib2-exec-prefix is passed to
+the configure script), which totally screws up the resulting linker flags.
+
+Inspired by: http://git.fluxbox.org/fluxbox.git/commit/?id=b178bed60b5bd8b2c9ed0cbc67fd729ff3820589
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+
+--- fluxbox-1.3.2.orig/configure.in 2012-10-21 16:11:59.445749396 +0200
++++ fluxbox-1.3.2/configure.in 2012-10-21 16:35:27.658390856 +0200
+@@ -443,8 +443,6 @@ if test x$enable_imlib2 = "xyes"; then
+ [
+ IMLIB2=true
+ AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support])
+- IMLIB2_LIBS=`imlib2-config --libs`
+- IMLIB2_CFLAGS=`imlib2-config --cflags`
+ LIBS="$LIBS $IMLIB2_LIBS"
+ CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS"
+ ], [ AC_MSG_RESULT(no)]