summaryrefslogtreecommitdiffstats
path: root/package/festival/speech-tools/speech-tools.mk
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-04-03 17:13:46 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-04-03 17:13:46 +0000
commitda53e2e09e40ba7437c3c002e58ef8f8fe7a5ac9 (patch)
tree3bfacb96c83b7f91acbf239286ce38b2e4cdc51e /package/festival/speech-tools/speech-tools.mk
parentf2f4131081962cf1185daa209d424ba72a1c9c36 (diff)
downloadbuildroot-novena-da53e2e09e40ba7437c3c002e58ef8f8fe7a5ac9.tar.gz
buildroot-novena-da53e2e09e40ba7437c3c002e58ef8f8fe7a5ac9.zip
add festival speech synthesis package from University of Edinburgh
Diffstat (limited to 'package/festival/speech-tools/speech-tools.mk')
-rw-r--r--package/festival/speech-tools/speech-tools.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/festival/speech-tools/speech-tools.mk b/package/festival/speech-tools/speech-tools.mk
new file mode 100644
index 000000000..087117bfe
--- /dev/null
+++ b/package/festival/speech-tools/speech-tools.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# speech-tools
+#
+#############################################################
+SPEECH_TOOLS_VERSION = 1.2.96-beta
+SPEECH_TOOLS_SOURCE = speech_tools-$(SPEECH_TOOLS_VERSION).tar.gz
+SPEECH_TOOLS_SITE = http://festvox.org/packed/festival/latest
+SPEECH_TOOLS_AUTORECONF = NO
+SPEECH_TOOLS_INSTALL_STAGING = NO
+SPEECH_TOOLS_INSTALL_TARGET = YES
+SPEECH_TOOLS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) STRIP=$(TARGET_STRIP) install
+
+SPEECH_TOOLS_CONF_OPT =
+SPEECH_TOOLS_MAKE_OPT = CC=$(TARGET_CC) CXX=$(TARGET_CXX)
+
+SPEECH_TOOLS_DEPENDENCIES = uclibc ncurses
+
+$(eval $(call AUTOTARGETS,package/festival,speech-tools))
+