summaryrefslogtreecommitdiffstats
path: root/package/efl/libedbus/libedbus.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-04-18 23:38:19 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-18 23:38:19 +0200
commit4b02a282089e37bfe134856da5c2e9fd21360ba8 (patch)
tree15bb8eae4e759094b3be67756d3a626619b2db09 /package/efl/libedbus/libedbus.mk
parente5ece0d8eebf2f908b952141130664d3a6430f67 (diff)
downloadbuildroot-novena-4b02a282089e37bfe134856da5c2e9fd21360ba8.tar.gz
buildroot-novena-4b02a282089e37bfe134856da5c2e9fd21360ba8.zip
libedbus: add options for bluez/connman/notify support
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/efl/libedbus/libedbus.mk')
-rw-r--r--package/efl/libedbus/libedbus.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/efl/libedbus/libedbus.mk b/package/efl/libedbus/libedbus.mk
index 34f34a7c0..c03474d9d 100644
--- a/package/efl/libedbus/libedbus.mk
+++ b/package/efl/libedbus/libedbus.mk
@@ -11,4 +11,24 @@ LIBEDBUS_INSTALL_STAGING = YES
LIBEDBUS_DEPENDENCIES = host-pkg-config dbus libeina libecore
+ifeq ($(BR2_PACKAGE_LIBEDBUS_BLUEZ),y)
+LIBEDBUS_CONF_OPT += --enable-ebluez
+LIBEDBUS_DEPENDENCIES += bluez_utils
+else
+LIBEDBUS_CONF_OPT += --disable-ebluez
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_CONNMAN),y)
+LIBEDBUS_CONF_OPT += --enable-econnman0_7x
+LIBEDBUS_DEPENDENCIES += connman
+else
+LIBEDBUS_CONF_OPT += --disable-econnman0_7x
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_NOTIFY),y)
+LIBEDBUS_CONF_OPT += --enable-enotify --disable-edbus-notify-test
+else
+LIBEDBUS_CONF_OPT += --disable-enotify
+endif
+
$(eval $(call AUTOTARGETS))