summaryrefslogtreecommitdiffstats
path: root/package/config/Makefile.kconfig
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-19 08:11:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-19 08:11:43 +0000
commit1b6f2e0f4c8445100f1ea6bea5b89db15dba0175 (patch)
tree47203e44f22361896d63103608f32c2d8ba87e13 /package/config/Makefile.kconfig
parent2c2796719afce7b7a64fa1dd0bec736b10e371da (diff)
downloadbuildroot-novena-1b6f2e0f4c8445100f1ea6bea5b89db15dba0175.tar.gz
buildroot-novena-1b6f2e0f4c8445100f1ea6bea5b89db15dba0175.zip
package/config: rebase from upstream (2.6.23.14)
From Bernhards tree (2737cfdd)
Diffstat (limited to 'package/config/Makefile.kconfig')
-rw-r--r--package/config/Makefile.kconfig35
1 files changed, 18 insertions, 17 deletions
diff --git a/package/config/Makefile.kconfig b/package/config/Makefile.kconfig
index 3288a2c60..0b70e63d2 100644
--- a/package/config/Makefile.kconfig
+++ b/package/config/Makefile.kconfig
@@ -22,24 +22,25 @@ oldconfig: $(obj)/conf
silentoldconfig: $(obj)/conf
$< -s arch/$(ARCH)/Kconfig
+# Create new linux.po file
+# Adjust charset to UTF-8 in .po file to accept UTF-8 in Kconfig files
+# The symlink is used to repair a deficiency in arch/um
update-po-config: $(obj)/kxgettext
- xgettext --default-domain=linux \
- --add-comments --keyword=_ --keyword=N_ \
- --files-from=scripts/kconfig/POTFILES.in \
- --output scripts/kconfig/config.pot
- $(Q)ln -fs Kconfig_i386 arch/um/Kconfig_arch
- $(Q)for i in `ls arch/`; \
- do \
- scripts/kconfig/kxgettext arch/$$i/Kconfig \
- | msguniq -o scripts/kconfig/linux_$${i}.pot; \
- done
- $(Q)msgcat scripts/kconfig/config.pot \
- `find scripts/kconfig/ -type f -name linux_*.pot` \
- --output scripts/kconfig/linux_raw.pot
- $(Q)msguniq --sort-by-file scripts/kconfig/linux_raw.pot \
- --output scripts/kconfig/linux.pot
- $(Q)rm -f arch/um/Kconfig_arch
- $(Q)rm -f scripts/kconfig/linux_*.pot scripts/kconfig/config.pot
+ xgettext --default-domain=linux \
+ --add-comments --keyword=_ --keyword=N_ \
+ --from-code=UTF-8 \
+ --files-from=scripts/kconfig/POTFILES.in \
+ --output $(obj)/config.pot
+ $(Q)sed -i s/CHARSET/UTF-8/ $(obj)/config.pot
+ $(Q)ln -fs Kconfig.i386 arch/um/Kconfig.arch
+ (for i in `ls arch/`; \
+ do \
+ $(obj)/kxgettext arch/$$i/Kconfig; \
+ done ) >> $(obj)/config.pot
+ msguniq --sort-by-file --to-code=UTF-8 $(obj)/config.pot \
+ --output $(obj)/linux.pot
+ $(Q)rm -f arch/um/Kconfig.arch
+ $(Q)rm -f $(obj)/config.pot
PHONY += randconfig allyesconfig allnoconfig allmodconfig defconfig