summaryrefslogtreecommitdiffstats
path: root/package/cmake
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:09:58 +0200
commit0849e8193ef429f29945b8c2a54eafc8635e0969 (patch)
tree87934d420647a042d53c0332e15d4d02404b8010 /package/cmake
parente055aea216cff4d12cf55eab2e35ca1459edaa91 (diff)
downloadbuildroot-novena-0849e8193ef429f29945b8c2a54eafc8635e0969.tar.gz
buildroot-novena-0849e8193ef429f29945b8c2a54eafc8635e0969.zip
package: remove useless arguments from GENTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the GENTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cmake')
-rw-r--r--package/cmake/cmake.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/cmake/cmake.mk b/package/cmake/cmake.mk
index 1b458c219..af88eea82 100644
--- a/package/cmake/cmake.mk
+++ b/package/cmake/cmake.mk
@@ -17,5 +17,5 @@ define HOST_CMAKE_INSTALL_CMDS
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
endef
-$(eval $(call GENTARGETS,package,cmake))
-$(eval $(call GENTARGETS,package,cmake,host)) \ No newline at end of file
+$(eval $(call GENTARGETS))
+$(eval $(call GENTARGETS,host))