summaryrefslogtreecommitdiffstats
path: root/package/cache-calibrator/cache-calibrator.mk
diff options
context:
space:
mode:
authorStephan Hoffmann <sho@relinux.de>2013-01-28 23:53:52 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-29 21:34:09 +0100
commit3c80d680f2e4d3e568bfeef2c46ceccc952db42d (patch)
treedbf8ccd8141a3123e8e39a73c17f9768a374ddb6 /package/cache-calibrator/cache-calibrator.mk
parent42169a4e71bf02e496aab3b8dccc3f2e800559eb (diff)
downloadbuildroot-novena-3c80d680f2e4d3e568bfeef2c46ceccc952db42d.tar.gz
buildroot-novena-3c80d680f2e4d3e568bfeef2c46ceccc952db42d.zip
New package: cache-calibrator
The Calibrator is a small C program that is supposed to analyze a computers (cache-) memory system and extract the following parameters: number of cache levels for each cache level: its size its linesize its access/miss latency main memory access latency number of TLB levels for each TLB level: its capacity (i.e. number of entries) the pagesize used the TLB miss latency http://homepages.cwi.nl/~manegold/Calibrator/ It is also recommended as a load generator for realtime testing in: https://rt.wiki.kernel.org/index.php/RT_PREEMPT_HOWTO#Benchmarking [Peter: reformat help text, fix extract step] Signed-off-by: Stephan Hoffmann <sho@relinux.de> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cache-calibrator/cache-calibrator.mk')
-rw-r--r--package/cache-calibrator/cache-calibrator.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/cache-calibrator/cache-calibrator.mk b/package/cache-calibrator/cache-calibrator.mk
new file mode 100644
index 000000000..35c9f9491
--- /dev/null
+++ b/package/cache-calibrator/cache-calibrator.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# cache-calibrator
+#
+#############################################################
+
+CACHE_CALIBRATOR_SOURCE = calibrator.c
+CACHE_CALIBRATOR_SITE = http://homepages.cwi.nl/~manegold/Calibrator/src
+CACHE_CALIBRATOR_LICENSE = Cache calibrator license
+CACHE_CALIBRATOR_LICENSE_FILES = calibrator.c
+
+define CACHE_CALIBRATOR_EXTRACT_CMDS
+ cp $(DL_DIR)/$(CACHE_CALIBRATOR_SOURCE) $(@D)
+endef
+
+define CACHE_CALIBRATOR_BUILD_CMDS
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) $(@D)/calibrator.c -o $(@D)/cache_calibrator -lm
+endef
+
+define CACHE_CALIBRATOR_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/cache_calibrator $(TARGET_DIR)/usr/bin/cache_calibrator
+endef
+
+$(eval $(generic-package))