summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-04-12 20:32:45 +0000
committerEric Andersen <andersen@codepoet.org>2005-04-12 20:32:45 +0000
commit9fc890fc1faf265c473c5aa26522aaa1d3bc77fd (patch)
treec66b14d1391ea7cd42b76bde4ad51f7bfaf0a578 /package/busybox
parent6e8666ead8d62a6334fc036e48bde7e16d4f21e8 (diff)
downloadbuildroot-novena-9fc890fc1faf265c473c5aa26522aaa1d3bc77fd.tar.gz
buildroot-novena-9fc890fc1faf265c473c5aa26522aaa1d3bc77fd.zip
Make busybox config file location a config option
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Config.in17
-rw-r--r--package/busybox/busybox.mk4
2 files changed, 17 insertions, 4 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 320cb9b1c..c9b0badf3 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -1,5 +1,5 @@
config BR2_PACKAGE_BUSYBOX
- bool "busybox"
+ bool "BusyBox"
default y
help
The Swiss Army Knife of embedded Linux. It slices, it dices, it
@@ -10,10 +10,21 @@ config BR2_PACKAGE_BUSYBOX
Most people will answer Y.
config BR2_PACKAGE_BUSYBOX_SNAPSHOT
- bool "Use the daily snapshot of busybox?"
+ bool "Use the daily snapshot of BusyBox?"
depends BR2_PACKAGE_BUSYBOX
default y
help
- Use the latest busybox CVS snapshot instead of release.
+ Use the latest BusyBox daily snapshot instead of release.
For fun, you should say Y.
+
+config BR2_PACKAGE_BUSYBOX_CONFIG
+ string "BusyBox configuration file to use?"
+ depends BR2_PACKAGE_BUSYBOX
+ default "package/busybox/busybox.config"
+ help
+ Some people may wish to use their own modified BusyBox configuration
+ file, and will specify their config file location with this option.
+
+ Most people will just use the default BusyBox configuration file.
+
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 0013f4a74..e090feb6d 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -16,7 +16,9 @@ BUSYBOX_SOURCE:=busybox-$(BUSYBOX_VER).tar.bz2
BUSYBOX_SITE:=http://www.busybox.net/downloads
endif
BUSYBOX_UNZIP=bzcat
-BUSYBOX_CONFIG_FILE=package/busybox/busybox.config
+
+BUSYBOX_CONFIG_FILE=$(subst ",, $(strip $(BR2_PACKAGE_BUSYBOX_CONFIG)))
+#"
$(DL_DIR)/$(BUSYBOX_SOURCE):
$(WGET) -P $(DL_DIR) $(BUSYBOX_SITE)/$(BUSYBOX_SOURCE)