summaryrefslogtreecommitdiffstats
path: root/package/boost/boost.mk
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2013-06-11 08:30:03 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-11 11:58:27 +0200
commite2f28217816174550dc5858fbb4f1d68ee5f0c20 (patch)
tree0747f1a77d49f8ae1bb6b97ec594df6b3fed07ff /package/boost/boost.mk
parentc6bccfa880a9b82c071303c87fe0779ac621329d (diff)
downloadbuildroot-novena-e2f28217816174550dc5858fbb4f1d68ee5f0c20.tar.gz
buildroot-novena-e2f28217816174550dc5858fbb4f1d68ee5f0c20.zip
boost: only the iostreams library requires bzip2 and zlib
Signed-off-by: Will Wagner <will_wagner@carallon.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/boost/boost.mk')
-rw-r--r--package/boost/boost.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 57d021ae4..ce729901a 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -12,7 +12,7 @@ BOOST_INSTALL_STAGING = YES
TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
-BOOST_DEPENDENCIES = bzip2 zlib
+BOOST_DEPENDENCIES =
BOOST_FLAGS =
@@ -48,6 +48,10 @@ else
BOOST_FLAGS += --without-icu
endif
+ifeq ($(BR2_PACKAGE_BOOST_IOSTREAMS),y)
+BOOST_DEPENDENCIES += bzip2 zlib
+endif
+
BOOST_OPT += toolset=gcc \
threading=multi \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \