summaryrefslogtreecommitdiffstats
path: root/package/am33x-cm3/am33x-cm3.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-02 16:33:05 +0200
commit1ba51d2fbddd5650f8caea0a327b9031238ad843 (patch)
tree05d5df7b487e76597b34cb0b1fc9543525169a62 /package/am33x-cm3/am33x-cm3.mk
parent0c94aa549cc8cf483bc8c3443a2b1f772d5d180b (diff)
parentfb2f3d58bde6aaac12b62eeb16492c93329b8713 (diff)
downloadbuildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.tar.gz
buildroot-novena-1ba51d2fbddd5650f8caea0a327b9031238ad843.zip
Merge branch 'next'
Diffstat (limited to 'package/am33x-cm3/am33x-cm3.mk')
-rw-r--r--package/am33x-cm3/am33x-cm3.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/am33x-cm3/am33x-cm3.mk b/package/am33x-cm3/am33x-cm3.mk
new file mode 100644
index 000000000..3805c8022
--- /dev/null
+++ b/package/am33x-cm3/am33x-cm3.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# am33x-cm3
+#
+#############################################################
+
+AM33X_CM3_VERSION = AM335xPSP_04.06.00.10-rc1
+AM33X_CM3_SITE = http://arago-project.org/git/projects/am33x-cm3.git
+AM33X_CM3_SITE_METHOD = git
+AM33X_CM3_LICENSE = TI Publicly Available Software License
+AM33X_CM3_LICENSE_FILES = License.txt
+
+# The build command below will use the standard cross-compiler (normally
+# build for Cortex-A8, to build the FW for the Cortex-M3.
+define AM33X_CM3_BUILD_CMDS
+ $(MAKE) CC="$(TARGET_CC)" CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) all
+endef
+
+# Not all of the firmware files are used
+define AM33X_CM3_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0644 -D $(@D)/bin/am335x-pm-firmware.bin \
+ $(TARGET_DIR)/lib/firmware/am335x-pm-firmware.bin
+endef
+
+define AM33X_CM3_INSTALL_INIT_SYSV
+ $(INSTALL) -m 0755 -D package/am33x-cm3/S93-am335x-pm-firmware-load \
+ $(TARGET_DIR)/etc/init.d/S93-am335x-pm-firmware-load
+endef
+
+$(eval $(generic-package))