summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-21 13:51:53 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-21 13:51:53 +0000
commit3c9baee374857de425a0e14f0f13ad27491006be (patch)
tree7f8ef9f22cb435dd37a76d7adb5df60a28924cf6 /package/Makefile.in
parent405aadb356f830cb995b4fff11b1b85d8738697b (diff)
downloadbuildroot-novena-3c9baee374857de425a0e14f0f13ad27491006be.tar.gz
buildroot-novena-3c9baee374857de425a0e14f0f13ad27491006be.zip
- use centralized DISABLE_LARGEFILE
- nil CXX if there isn't one
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index aeb56d737..1e10e4c1b 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -16,11 +16,6 @@ TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
#")
-
-
-ifneq ($(BR2_LARGEFILE),y)
-DISABLE_LARGEFILE= --disable-largefile
-endif
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
HOSTCC:=gcc
HOSTCXX:=g++
@@ -101,4 +96,11 @@ else
DISABLE_NLS:=--disable-nls
endif
+ifneq ($(BR2_LARGEFILE),y)
+DISABLE_LARGEFILE= --disable-largefile
+endif
+
+ifeq ($(BR2_INSTALL_LIBSTDCPP),)
+TARGET_CONFIGURE_OPTS+=CXX=""
+endif