summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-20 00:02:13 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-20 00:02:13 +0000
commitf02886e2f044898687daef6ca8f33e77cc86341c (patch)
treec7617625e8ec977ee5468f1c9e1437eca7e0b9b8 /make
parent60f17faa102a462974872211d62176390758136b (diff)
downloadbuildroot-novena-f02886e2f044898687daef6ca8f33e77cc86341c.tar.gz
buildroot-novena-f02886e2f044898687daef6ca8f33e77cc86341c.zip
Fixup the regex used for iptables so it actually works
Diffstat (limited to 'make')
-rw-r--r--make/iptables.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/make/iptables.mk b/make/iptables.mk
index edebaff78..56bbf1b27 100644
--- a/make/iptables.mk
+++ b/make/iptables.mk
@@ -15,9 +15,8 @@ $(IPTABLES_BUILD_DIR)/.unpacked: $(DL_DIR)/$(IPTABLES_SOURCE)
touch $(IPTABLES_BUILD_DIR)/.unpacked
$(IPTABLES_BUILD_DIR)/.configured: $(IPTABLES_BUILD_DIR)/.unpacked
- $(SED) "s@shell.*YES.*@shell grep -q '__UCLIBC_HAS_IPV6__.*1' \
- $(BUILD_DIR)/uClibc/include/bits/uClibc_config.h && \
- echo YES\), YES\)@;" $(IPTABLES_BUILD_DIR)/Makefile
+ $(SED) "s;\[ -f /usr/include/netinet/ip6.h \];grep -q '__UCLIBC_HAS_IPV6__ 1' \
+ $(BUILD_DIR)/uClibc/include/bits/uClibc_config.h;" $(IPTABLES_BUILD_DIR)/Makefile
touch $(IPTABLES_BUILD_DIR)/.configured
$(IPTABLES_BUILD_DIR)/iptables: $(IPTABLES_BUILD_DIR)/.configured