summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-02-27 00:26:57 +0000
committerEric Andersen <andersen@codepoet.org>2004-02-27 00:26:57 +0000
commitae43b56d6a50e06ab6fe6805ee8ad510c734f837 (patch)
tree389e8f80ba48a25fa352466ce461b0588ae29af1 /make
parentc9d77299142ecfa7562e0db4798bbb60515af8e3 (diff)
downloadbuildroot-novena-ae43b56d6a50e06ab6fe6805ee8ad510c734f837.tar.gz
buildroot-novena-ae43b56d6a50e06ab6fe6805ee8ad510c734f837.zip
Better deal with arches like mips that have odd kernel dir naming
Diffstat (limited to 'make')
-rw-r--r--make/linux.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/make/linux.mk b/make/linux.mk
index 2600afc01..442c55b3d 100644
--- a/make/linux.mk
+++ b/make/linux.mk
@@ -27,6 +27,11 @@ DOWNLOAD_LINUX_VERSION=2.4.23
LINUX_VERSION=2.4.23-erik
LINUX_FORMAT=bzImage
+LINUX_KARCH:= echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ sed -e 's/mipsel/mips/' \
+ sed -e 's/powerpc/ppc/' \
+ sed -e 's/sh[234]/sh/'
+LINUX_BINLOC=arch/$(LINUX_KARCH)/boot/$(LINUX_FORMAT)
LINUX_BINLOC=arch/$(ARCH)/boot/$(LINUX_FORMAT)
#LINUX_FORMAT=zImage
#LINUX_BINLOC=arch/ppc/boot/images/zImage.prep