summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-06-23 21:05:54 +0000
committerEric Andersen <andersen@codepoet.org>2003-06-23 21:05:54 +0000
commitaa5091d50c5dfd99145c9e6e3523e02d9ca7a2a1 (patch)
tree45ddebe36d925d956bb459282ebf1561359d750e /make
parentded9ff0bccc09461a140462a2b4a8a08508352ac (diff)
downloadbuildroot-novena-aa5091d50c5dfd99145c9e6e3523e02d9ca7a2a1.tar.gz
buildroot-novena-aa5091d50c5dfd99145c9e6e3523e02d9ca7a2a1.zip
Add support for the Dropbear SSH server
Diffstat (limited to 'make')
-rw-r--r--make/dropbear_sshd.mk64
1 files changed, 64 insertions, 0 deletions
diff --git a/make/dropbear_sshd.mk b/make/dropbear_sshd.mk
new file mode 100644
index 000000000..e8f10d0f8
--- /dev/null
+++ b/make/dropbear_sshd.mk
@@ -0,0 +1,64 @@
+#############################################################
+#
+# dropbear_sshd
+#
+#############################################################
+DROPBEAR_SSHD_SOURCE:=dropbear-0.33.tar.bz2
+DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/
+DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.33
+DROPBEAR_SSHD_CAT:=bzcat
+DROPBEAR_SSHD_BINARY:=dropbear
+DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
+DROPBEAR_SSHD_PATCH:=$(SOURCE_DIR)/dropbear.patch
+
+
+$(DL_DIR)/$(DROPBEAR_SSHD_SOURCE):
+ $(WGET) -P $(DL_DIR) $(DROPBEAR_SSHD_SITE)/$(DROPBEAR_SSHD_SOURCE)
+
+dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
+
+$(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
+ $(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ cat $(DROPBEAR_SSHD_PATCH) | patch -p1 -d $(DROPBEAR_SSHD_DIR)
+ touch $(DROPBEAR_SSHD_DIR)/.unpacked
+
+$(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
+ (cd $(DROPBEAR_SSHD_DIR); rm -rf config.cache; \
+ autoconf; \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
+ --with-shared \
+ );
+ touch $(DROPBEAR_SSHD_DIR)/.configured
+
+$(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR)
+
+$(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+
+dropbear_sshd: uclibc $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+
+dropbear_sshd-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) uninstall
+ -$(MAKE) -C $(DROPBEAR_SSHD_DIR) clean
+
+dropbear_sshd-dirclean:
+ rm -rf $(DROPBEAR_SSHD_DIR)
+