summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-07 05:23:30 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-07 05:23:30 +0000
commit977c7bd5ae42618046145891c937e5a3a7fa94ae (patch)
treec6a689e51d0a3a93f45203f9f9386da16ce9cba5 /make
parentd30258309f7f132512d139b90f979a875bc38b57 (diff)
downloadbuildroot-novena-977c7bd5ae42618046145891c937e5a3a7fa94ae.tar.gz
buildroot-novena-977c7bd5ae42618046145891c937e5a3a7fa94ae.zip
make sure we have a directory before trying to install symlinks
Diffstat (limited to 'make')
-rw-r--r--make/gcc-3.3.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/gcc-3.3.mk b/make/gcc-3.3.mk
index 077e02a0a..b00b3026d 100644
--- a/make/gcc-3.3.mk
+++ b/make/gcc-3.3.mk
@@ -290,7 +290,8 @@ $(TARGET_DIR)/lib/libstdc++.so.5.0.5: $(GCC_BUILD_DIR2)/.installed
$(TARGET_DIR)/lib/libgcc_s.so.0.9.9: $(GCC_BUILD_DIR2)/.installed
cp -a $(STAGING_DIR)/lib/libgcc_s.so* $(TARGET_DIR)/lib/
- # Enable applications to link with the shared ligbcc.
+ # Let applications link with the shared libgcc.
+ mkdir -p $(STAGING_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/
ln -sf $(STAGING_DIR)/lib/libgcc_s.so $(STAGING_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/libgcc.so
ifeq ($(INSTALL_LIBSTDCPP),true)