summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-09-02 12:22:02 +0000
committerEric Andersen <andersen@codepoet.org>2003-09-02 12:22:02 +0000
commit92cecf265ec79ad2f633dbdebddb1a4238002d7a (patch)
treea1d748b8a10c02cb17583f70b8d55e5f661e5562 /make
parentc9e50edded82304cbd360433f14b4f00e5159a59 (diff)
downloadbuildroot-novena-92cecf265ec79ad2f633dbdebddb1a4238002d7a.tar.gz
buildroot-novena-92cecf265ec79ad2f633dbdebddb1a4238002d7a.zip
Make sure binutils does not leak system libraries into the build.
patch from mjn3 to prevent gcc using broken include paths
Diffstat (limited to 'make')
-rw-r--r--make/uclibc_toolchain.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 94e3823cf..cdc5321a7 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -148,8 +148,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
--mandir=$(STAGING_DIR)/man \
--infodir=$(STAGING_DIR)/info \
--enable-targets=$(GNU_TARGET_NAME) \
- --with-lib-path="/usr/lib:/lib" \
--with-sysroot=$(STAGING_DIR) \
+ --with-lib-path="$(STAGING_DIR)/usr/lib:$(STAGING_DIR)/lib" \
$(MULTILIB) \
--program-prefix=$(ARCH)-uclibc-);
touch $(BINUTILS_DIR1)/.configured