summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-17 04:50:35 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-17 04:50:35 +0000
commit8e081ea611483c35a17e0a5c3e80a943b27ab0a2 (patch)
tree642e63cc759d1c78ad35fa1f67c78fcf23ea5078 /make
parent382187f0140af0f0f4a5b2c06a8b785ea3cd1ca8 (diff)
downloadbuildroot-novena-8e081ea611483c35a17e0a5c3e80a943b27ab0a2.tar.gz
buildroot-novena-8e081ea611483c35a17e0a5c3e80a943b27ab0a2.zip
be sure include dir is present
Diffstat (limited to 'make')
-rw-r--r--make/openssl.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/make/openssl.mk b/make/openssl.mk
index 15948c066..183781ee5 100644
--- a/make/openssl.mk
+++ b/make/openssl.mk
@@ -43,6 +43,7 @@ $(TARGET_DIR)/lib/libcrypto.so.0: $(STAGING_DIR)/lib/libcrypto.so.0
#cp -fa $(STAGING_DIR)/bin/openssl $(TARGET_DIR)/bin/
$(TARGET_DIR)/usr/include/openssl/crypto.h: $(TARGET_DIR)/lib/libcrypto.so.0
+ mkdir -p $(TARGET_DIR)/usr/include
cp -a $(STAGING_DIR)/include/openssl $(TARGET_DIR)/usr/include/
cp -dpf $(STAGING_DIR)/lib/libssl.a $(TARGET_DIR)/usr/lib/
cp -dpf $(STAGING_DIR)/lib/libcrypto.a $(TARGET_DIR)/usr/lib/