summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-03 17:18:41 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-03 17:18:41 +0000
commit435a4f723af2fc016eed62fe14175ab4867a522e (patch)
tree9d5745587d637f7b176b8057bab182c97b3337e8 /make
parent8e34cf6f85319d0e0c7ee8c887329b9c0a9d2e82 (diff)
downloadbuildroot-novena-435a4f723af2fc016eed62fe14175ab4867a522e.tar.gz
buildroot-novena-435a4f723af2fc016eed62fe14175ab4867a522e.zip
Prevent install from following symlinks and overwriting bin/busybox
Diffstat (limited to 'make')
-rw-r--r--make/bzip2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/bzip2.mk b/make/bzip2.mk
index 6aa4a88df..299105a91 100644
--- a/make/bzip2.mk
+++ b/make/bzip2.mk
@@ -42,6 +42,8 @@ $(BZIP2_BINARY): $(STAGING_DIR)/lib/libbz2.so.1.0.2
$(MAKE) CC=$(TARGET_CC) -C $(BZIP2_DIR) bzip2 bzip2recover
$(BZIP2_TARGET_BINARY): $(BZIP2_BINARY)
+ (cd $(TARGET_DIR)/usr/bin; \
+ rm -f bzip2 bunzip2 bzcat bzip2recover bzgrep bzegrep bzfgrep bzmore bzless bzdiff bzcmp);
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(BZIP2_DIR) install
rm -f $(TARGET_DIR)/usr/lib/libbz2.a