summaryrefslogtreecommitdiffstats
path: root/make/uclibc_toolchain_2_95.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-13 20:30:07 +0000
commit9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f (patch)
tree3e8e5db9d2e2a229c2978e55217f263f0a27ae6d /make/uclibc_toolchain_2_95.mk
parent5b89b722a2c6c723a2b59ab3b950d16e6872eca8 (diff)
downloadbuildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.tar.gz
buildroot-novena-9c636934a0cbe7c5b1644ed3688a2a2cb3518d3f.zip
Do not blindly strip all symbols from from all libs. libpthread
needs its symbols for pthread debugging to work. Let it be a local decision.
Diffstat (limited to 'make/uclibc_toolchain_2_95.mk')
-rw-r--r--make/uclibc_toolchain_2_95.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/make/uclibc_toolchain_2_95.mk b/make/uclibc_toolchain_2_95.mk
index 3335d0483..9a040ddf3 100644
--- a/make/uclibc_toolchain_2_95.mk
+++ b/make/uclibc_toolchain_2_95.mk
@@ -510,9 +510,7 @@ $(STAGING_DIR)/bin/$(ARCH)-uclibc-g++: $(GCC_BUILD_DIR2)/.compiled
$(STAGING_DIR)/share/locale
# Strip the host binaries
-strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
- # Strip the target shared libs
- -$(STRIP) --strip-unneeded -R .note -R .comment $(STAGING_DIR)/lib/*.so*;
- set -e;
+ set -e; \
for app in cc gcc c89 cpp c++ g++ ; do \
if [ -x $(STAGING_DIR)/bin/$(ARCH)-uclibc-$${app} ] ; then \
(cd $(STAGING_DIR)/usr/bin; \