summaryrefslogtreecommitdiffstats
path: root/make/uclibc_toolchain_2_95.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-09-03 07:18:18 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-09-03 07:18:18 +0000
commit0e956fc164b97347279045e60033e6f2f176df3b (patch)
treebe9515a9bae85c641ce8c8756d378eb367614c4c /make/uclibc_toolchain_2_95.mk
parent2aaceb3dd6b542912a144d0c7860048091aedf4b (diff)
downloadbuildroot-novena-0e956fc164b97347279045e60033e6f2f176df3b.tar.gz
buildroot-novena-0e956fc164b97347279045e60033e6f2f176df3b.zip
Add support for enabling use of libintl.
Add support for libstd++ in full locale mode, and remove the need for config hacks when using uClibc stub locale support. TODO -- gdb intl support is still broken. uClibc should auto-download the pregenerated locale data
Diffstat (limited to 'make/uclibc_toolchain_2_95.mk')
-rw-r--r--make/uclibc_toolchain_2_95.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/make/uclibc_toolchain_2_95.mk b/make/uclibc_toolchain_2_95.mk
index adf7be89d..2f9c719ef 100644
--- a/make/uclibc_toolchain_2_95.mk
+++ b/make/uclibc_toolchain_2_95.mk
@@ -295,7 +295,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.gcc_build_hacks
--infodir=$(STAGING_DIR)/info \
--with-local-prefix=$(STAGING_DIR)/usr/local \
--oldincludedir=$(STAGING_DIR)/include $(MULTILIB) \
- --enable-target-optspace --disable-nls --with-gnu-ld \
+ --enable-target-optspace $(DISABLE_NLS) --with-gnu-ld \
--disable-shared --enable-languages=c --disable-__cxa_atexit \
$(EXTRA_GCC_CONFIG_OPTIONS) --program-prefix=$(ARCH)-uclibc-);
touch $(GCC_BUILD_DIR1)/.configured
@@ -488,7 +488,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.g++_build_hacks
--with-gxx-include-dir=$(STAGING_DIR)/include/c++ \
--oldincludedir=$(STAGING_DIR)/include \
--enable-shared $(MULTILIB) \
- --enable-target-optspace --disable-nls \
+ --enable-target-optspace $(DISABLE_NLS) \
--with-gnu-ld --disable-__cxa_atexit \
--enable-languages=$(TARGET_LANGUAGES) \
$(EXTRA_GCC_CONFIG_OPTIONS) \