summaryrefslogtreecommitdiffstats
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-17 08:51:21 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-17 08:51:21 +0000
commit5dbea59f53c0379168dd60782700be4422dbe0b6 (patch)
treebe4b4835758dc601a08a6354ba374d5083a13b37 /make/uclibc_toolchain.mk
parenta413a043f777611cf15419a4408ee60f0404b1a3 (diff)
downloadbuildroot-novena-5dbea59f53c0379168dd60782700be4422dbe0b6.tar.gz
buildroot-novena-5dbea59f53c0379168dd60782700be4422dbe0b6.zip
more minor installation cleanups
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk39
1 files changed, 26 insertions, 13 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index becfaa64e..01104bf1a 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -128,13 +128,20 @@ $(BINUTILS_DIR)/.patched: $(BINUTILS_DIR)/.unpacked
$(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
mkdir -p $(BINUTILS_DIR1)
(cd $(BINUTILS_DIR1); CC=$(HOSTCC) $(BINUTILS_DIR)/configure \
- --target=$(GNU_TARGET_NAME) --prefix=$(STAGING_DIR) \
- --exec-prefix=$(STAGING_DIR) --bindir=$(STAGING_DIR)/bin \
- --sbindir=$(STAGING_DIR)/sbin --sysconfdir=$(STAGING_DIR)/etc \
- --datadir=$(STAGING_DIR)/share --includedir=$(STAGING_DIR)/include \
- --libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
- --mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
- --enable-targets=$(GNU_TARGET_NAME) $(MULTILIB) \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=$(STAGING_DIR) \
+ --exec-prefix=$(STAGING_DIR) \
+ --bindir=$(STAGING_DIR)/bin \
+ --sbindir=$(STAGING_DIR)/sbin \
+ --sysconfdir=$(STAGING_DIR)/etc \
+ --datadir=$(STAGING_DIR)/share \
+ --includedir=$(STAGING_DIR)/include \
+ --libdir=$(STAGING_DIR)/lib \
+ --localstatedir=$(STAGING_DIR)/var \
+ --mandir=$(STAGING_DIR)/man \
+ --infodir=$(STAGING_DIR)/info \
+ --enable-targets=$(GNU_TARGET_NAME) \
+ $(MULTILIB) \
--program-prefix=$(ARCH)-uclibc-);
touch $(BINUTILS_DIR1)/.configured
@@ -217,12 +224,18 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.gcc_build_hacks
mkdir -p $(GCC_BUILD_DIR1)
(cd $(GCC_BUILD_DIR1); PATH=$(STAGING_DIR)/bin:$$PATH AR=$(ARCH)-uclibc-ar \
RANLIB=$(ARCH)-uclibc-ranlib CC=$(HOSTCC) $(GCC_DIR)/configure \
- --target=$(GNU_TARGET_NAME) --prefix=$(STAGING_DIR) \
- --exec-prefix=$(STAGING_DIR) --bindir=$(STAGING_DIR)/bin \
- --sbindir=$(STAGING_DIR)/sbin --sysconfdir=$(STAGING_DIR)/etc \
- --datadir=$(STAGING_DIR)/share --includedir=$(STAGING_DIR)/include \
- --libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
- --mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=$(STAGING_DIR) \
+ --exec-prefix=$(STAGING_DIR) \
+ --bindir=$(STAGING_DIR)/bin \
+ --sbindir=$(STAGING_DIR)/sbin \
+ --sysconfdir=$(STAGING_DIR)/etc \
+ --datadir=$(STAGING_DIR)/share \
+ --includedir=$(STAGING_DIR)/include \
+ --libdir=$(STAGING_DIR)/lib \
+ --localstatedir=$(STAGING_DIR)/var \
+ --mandir=$(STAGING_DIR)/man \
+ --infodir=$(STAGING_DIR)/info \
--with-local-prefix=$(STAGING_DIR)/usr/local \
--oldincludedir=$(STAGING_DIR)/include $(MULTILIB) \
--enable-target-optspace --disable-nls --with-gnu-ld \