summaryrefslogtreecommitdiffstats
path: root/make/tinylogin.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/tinylogin.mk
parent93b677ea4256da1236ae5c4a14b78010e60266d9 (diff)
downloadbuildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.tar.gz
buildroot-novena-4f889ada561fbdffeefa1a8327d5b8939b021685.zip
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/tinylogin.mk')
-rw-r--r--make/tinylogin.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/make/tinylogin.mk b/make/tinylogin.mk
index 82faddc50..d15aa49b1 100644
--- a/make/tinylogin.mk
+++ b/make/tinylogin.mk
@@ -24,12 +24,12 @@ tinylogin-source: $(DL_DIR)/$(TINYLOGIN_SOURCE)
$(TINYLOGIN_DIR)/Config.h: $(DL_DIR)/$(TINYLOGIN_SOURCE)
bzcat $(DL_DIR)/$(TINYLOGIN_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- sed -i -e "s/\`id -u\` -ne 0/0 == 1/" \
+ $(SED) "s/\`id -u\` -ne 0/0 == 1/" \
$(TINYLOGIN_DIR)/install.sh
- sed -i -e "s/4755 --owner=root --group=root/755/" \
+ $(SED) "s/4755 --owner=root --group=root/755/" \
$(TINYLOGIN_DIR)/install.sh
- sed -i -e "s/^DOSTATIC.*/DOSTATIC=false/g;" $(TINYLOGIN_DIR)/Makefile
- sed -i -e "s/^DODEBUG.*/DODEBUG=false/g;" $(TINYLOGIN_DIR)/Makefile
+ $(SED) "s/^DOSTATIC.*/DOSTATIC=false/g;" $(TINYLOGIN_DIR)/Makefile
+ $(SED) "s/^DODEBUG.*/DODEBUG=false/g;" $(TINYLOGIN_DIR)/Makefile
# date test this one
touch $(TINYLOGIN_DIR)/Config.h