summaryrefslogtreecommitdiffstats
path: root/make/pppd.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/pppd.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
downloadbuildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.tar.gz
buildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.zip
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/pppd.mk')
-rw-r--r--make/pppd.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/make/pppd.mk b/make/pppd.mk
index da7684070..f023fb38e 100644
--- a/make/pppd.mk
+++ b/make/pppd.mk
@@ -18,10 +18,10 @@ pppd-source: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_CAT) $(DL_DIR)/$(PPPD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- perl -i -p -e 's/ -DIPX_CHANGE -DHAVE_MULTILINK -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
- perl -i -p -e 's/$(INSTALL) -s/$(INSTALL)/' $(PPPD_DIR)/*/Makefile.linux
- perl -i -p -e 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
- perl -i -p -e 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
+ sed -ie 's/ -DIPX_CHANGE -DHAVE_MULTILINK -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
+ sed -ie 's/$(INSTALL) -s/$(INSTALL)/' $(PPPD_DIR)/*/Makefile.linux
+ sed -ie 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
+ sed -ie 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
touch $(PPPD_DIR)/.unpacked
$(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked