summaryrefslogtreecommitdiffstats
path: root/make/openssl.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
commit0fee9e90c2ea3accfaa521a303c6568ebf7baccc (patch)
tree2d18515f482954fb771dc19671c9056511f71127 /make/openssl.mk
parente150f3921b20b1b35a42d0b34067773814675d8a (diff)
downloadbuildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.tar.gz
buildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.zip
Thomas Cameron writes:
this patch fixes the source file downloads when executing a "make source", and a few cut-and-paste (tm) errors in the *.mk files. Again, this is a patch against the current CVS sources, and includes my previous patch.
Diffstat (limited to 'make/openssl.mk')
-rw-r--r--make/openssl.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/make/openssl.mk b/make/openssl.mk
index 729ce06d4..073d0f7d8 100644
--- a/make/openssl.mk
+++ b/make/openssl.mk
@@ -63,6 +63,10 @@ $(TARGET_DIR)/usr/lib/libssl.a: $(STAGING_DIR)/lib/libcrypto.a
openssl-headers: $(TARGET_DIR)/usr/lib/libssl.a
+openssl: uclibc $(TARGET_DIR)/usr/lib/libcrypto.so.0.9.7
+
+openssl-source: $(DL_DIR)/$(OPENSSL_SOURCE)
+
openssl-clean:
rm -f $(STAGING_DIR)/bin/openssl $(TARGET_DIR)/bin/openssl
rm -f $(STAGING_DIR)/lib/libcrypto.so* $(TARGET_DIR)/lib/libcrypto.so*
@@ -72,5 +76,3 @@ openssl-clean:
openssl-dirclean:
rm -rf $(OPENSSL_DIR)
-openssl: uclibc $(TARGET_DIR)/usr/lib/libcrypto.so.0.9.7
-