summaryrefslogtreecommitdiffstats
path: root/make/ncurses.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-16 22:04:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-16 22:04:22 +0000
commiteffd2aa39da6e4f36f96dfde0aed6d75f5b1cdf3 (patch)
tree89001fe8d494754a569d4611aa1256506bf0ab44 /make/ncurses.mk
parent9a9de8dec9084f1b6048676a12fb9454ce0a5f7a (diff)
downloadbuildroot-novena-effd2aa39da6e4f36f96dfde0aed6d75f5b1cdf3.tar.gz
buildroot-novena-effd2aa39da6e4f36f96dfde0aed6d75f5b1cdf3.zip
Fixup ncurses installation of terminfo data
-Erik
Diffstat (limited to 'make/ncurses.mk')
-rw-r--r--make/ncurses.mk25
1 files changed, 8 insertions, 17 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index 855ee47b5..8ab30c2e7 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.14 2003/01/09 20:28:10 andersen Exp $
+# $Id: ncurses.mk,v 1.15 2003/01/16 22:04:22 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -63,7 +63,7 @@ $(NCURSES_DIR)/lib/libncurses.so: $(NCURSES_DIR)/.configured
$(MAKE) CC=$(TARGET_CC1) HOSTCC=$(HOSTCC) \
DESTDIR=$(STAGING_DIR) -C $(NCURSES_DIR)
-$(STAGING_DIR)/lib/libncurses.so: $(NCURSES_DIR)/lib/libncurses.so
+$(STAGING_DIR)/lib/libncurses.a: $(NCURSES_DIR)/lib/libncurses.so
PATH=$(STAGING_DIR)/bin:$$PATH BUILD_CC=$(HOSTCC) \
HOSTCC=$(HOSTCC) CC=$(TARGET_CC1) $(MAKE) \
prefix=$(STAGING_DIR) \
@@ -79,25 +79,16 @@ $(STAGING_DIR)/lib/libncurses.so: $(NCURSES_DIR)/lib/libncurses.so
mandir=$(STAGING_DIR)/man \
includedir=$(STAGING_DIR)/include \
gxx_include_dir=$(STAGING_DIR)/include/c++ \
+ ticdir=$(STAGING_DIR)/usr/share/terminfo \
-C $(NCURSES_DIR) install;
- #cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
- #cp -dpf $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
- #cp -dpf $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
- #(cd $(STAGING_DIR)/include; ln -fs curses.h ncurses.h)
+ touch -c $(STAGING_DIR)/lib/libncurses.a
-$(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
- cp -dpf $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
+$(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.a
+ cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
-cp -dpf $(STAGING_DIR)/usr/lib/terminfo $(TARGET_DIR)/usr/lib/
+ mkdir -p $(TARGET_DIR)/usr/share/terminfo
for i in x/xterm x/xterm-color x/xterm-xfree86 v/vt100 v/vt200 a/ansi l/linux; do \
- cd $(STAGING_DIR)/usr/share/; \
- tar -cf - terminfo/$${i} | \
- tar -C $(TARGET_DIR)/usr/share/ -xf - ; \
+ cp -dpf $(STAGING_DIR)/usr/share/terminfo/$${i} $(TARGET_DIR)/usr/share/terminfo/; \
done
$(TARGET_DIR)/usr/include/ncurses.h: $(TARGET_DIR)/lib/libncurses.so