summaryrefslogtreecommitdiffstats
path: root/make/ncurses.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-05-29 14:26:13 +0000
committerEric Andersen <andersen@codepoet.org>2002-05-29 14:26:13 +0000
commit2181513aee7abee047f39d2c98a3fb82f07a1cbf (patch)
treed5cd8e20d6ff1a59aacb54bd8864600a223fb955 /make/ncurses.mk
parentdd0dc991660dad53fd30480722ba1e317a3df22f (diff)
downloadbuildroot-novena-2181513aee7abee047f39d2c98a3fb82f07a1cbf.tar.gz
buildroot-novena-2181513aee7abee047f39d2c98a3fb82f07a1cbf.zip
Fixup the make install step
Diffstat (limited to 'make/ncurses.mk')
-rw-r--r--make/ncurses.mk15
1 files changed, 13 insertions, 2 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index 6f564bbd3..24fffd912 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.1 2002/05/23 19:21:23 andersen Exp $
+# $Id: ncurses.mk,v 1.2 2002/05/29 14:26:13 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -57,7 +57,18 @@ $(NCURSES_DIR)/lib/libncurses.so: $(NCURSES_DIR)/Makefile
$(STAGING_DIR)/lib/libncurses.so: $(NCURSES_DIR)/lib/libncurses.so
@echo "==============installing ncurses into staging...."
- make -C $(NCURSES_DIR) install DESTDIR=$(STAGING_DIR)
+ #make -C $(NCURSES_DIR) PREFIX=$(STAGING_DIR) install
+ $(STRIP) --strip-unneeded $(GDB_DIR)/gdb/gdb
+ cp -a $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
+ cp -a $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
+ cp -a $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
+ (cd $(STAGING_DIR)/include; ln -s curses.h ncurses.h)
$(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
@echo "==============installing ncurses into root dir...."