summaryrefslogtreecommitdiffstats
path: root/make/gcc-uclibc-3.x.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
commit3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee (patch)
tree935da51d77ee95870a094a5ae927b52c2c56cd48 /make/gcc-uclibc-3.x.mk
parent7e7644913a5530adab36489fd8c499f34de7eac2 (diff)
downloadbuildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.tar.gz
buildroot-novena-3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee.zip
Patch by michael tesch <tesch1@gmail.com> ...
The real problem, only caused when you have a *.patch file in the main build directory, is that the Makefiles don't escape the globbing operator they're passing to patch-kernel.sh. Attached is a patch to fix that.
Diffstat (limited to 'make/gcc-uclibc-3.x.mk')
-rw-r--r--make/gcc-uclibc-3.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/gcc-uclibc-3.x.mk b/make/gcc-uclibc-3.x.mk
index cfa504998..ff44759cd 100644
--- a/make/gcc-uclibc-3.x.mk
+++ b/make/gcc-uclibc-3.x.mk
@@ -67,7 +67,7 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
$(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# Apply any files named gcc-*.patch from the source directory to gcc
- $(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR)/gcc/$(GCC_VERSION) *.patch
+ $(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR)/gcc/$(GCC_VERSION) \*.patch
# Note: The soft float situation has improved considerably with gcc 3.4.x.
# We can dispense with the custom spec files, as well as libfloat for the arm case.
# However, we still need a patch for arm. There's a similar patch for gcc 3.3.x