summaryrefslogtreecommitdiffstats
path: root/make/gcc-2.95.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
commit0fee9e90c2ea3accfaa521a303c6568ebf7baccc (patch)
tree2d18515f482954fb771dc19671c9056511f71127 /make/gcc-2.95.mk
parente150f3921b20b1b35a42d0b34067773814675d8a (diff)
downloadbuildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.tar.gz
buildroot-novena-0fee9e90c2ea3accfaa521a303c6568ebf7baccc.zip
Thomas Cameron writes:
this patch fixes the source file downloads when executing a "make source", and a few cut-and-paste (tm) errors in the *.mk files. Again, this is a patch against the current CVS sources, and includes my previous patch.
Diffstat (limited to 'make/gcc-2.95.mk')
-rw-r--r--make/gcc-2.95.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/make/gcc-2.95.mk b/make/gcc-2.95.mk
index 83289107e..9c7d13c06 100644
--- a/make/gcc-2.95.mk
+++ b/make/gcc-2.95.mk
@@ -48,6 +48,7 @@ endif
#
#############################################################
GCC_BUILD_DIR1:=$(TOOL_BUILD_DIR)/gcc-2.95-initial
+
$(DL_DIR)/$(GCC_SOURCE):
$(WGET) -P $(DL_DIR) $(GCC_SITE)/$(GCC_SOURCE)
@@ -170,6 +171,7 @@ gcc2_95_initial-dirclean:
#
#############################################################
STLPORT_PATCH=$(SOURCE_DIR)/STLport-4.5.3.patch
+
$(DL_DIR)/$(STLPORT_SOURCE):
$(WGET) -P $(DL_DIR) $(STLPORT_SITE)/$(STLPORT_SOURCE)
@@ -188,6 +190,8 @@ endif
stlport: $(STAGING_DIR)/lib/libstdc++.a
+stlport-source: $(DL_DIR)/$(STLPORT_SOURCE)
+
stlport-clean:
rm -f $(STAGING_DIR)/lib/libstdc++*
rm -f $(STAGING_DIR)/include/c++*
@@ -280,6 +284,8 @@ $(STAGING_DIR)/bin/$(ARCH)-uclibc-g++: $(GCC_BUILD_DIR2)/.compiled
gcc2_95: binutils uclibc-configured gcc2_95_initial uclibc \
$(STAGING_DIR)/bin/$(ARCH)-uclibc-g++ $(STLPORT_TARGET)
+gcc2_95-source: $(DL_DIR)/$(GCC_SOURCE)
+
gcc2_95-clean:
rm -rf $(GCC_BUILD_DIR2)
rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)*