summaryrefslogtreecommitdiffstats
path: root/make/coreutils.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-09-03 07:18:18 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-09-03 07:18:18 +0000
commit0e956fc164b97347279045e60033e6f2f176df3b (patch)
treebe9515a9bae85c641ce8c8756d378eb367614c4c /make/coreutils.mk
parent2aaceb3dd6b542912a144d0c7860048091aedf4b (diff)
downloadbuildroot-novena-0e956fc164b97347279045e60033e6f2f176df3b.tar.gz
buildroot-novena-0e956fc164b97347279045e60033e6f2f176df3b.zip
Add support for enabling use of libintl.
Add support for libstd++ in full locale mode, and remove the need for config hacks when using uClibc stub locale support. TODO -- gdb intl support is still broken. uClibc should auto-download the pregenerated locale data
Diffstat (limited to 'make/coreutils.mk')
-rw-r--r--make/coreutils.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/make/coreutils.mk b/make/coreutils.mk
index e3e7fa39a..0d1d723d9 100644
--- a/make/coreutils.mk
+++ b/make/coreutils.mk
@@ -38,7 +38,7 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
- --disable-nls \
+ $(DISABLE_NLS) \
--disable-rpath \
--disable-dependency-tracking \
);
@@ -46,6 +46,9 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
# is not set when cross compiling
perl -i -p -e 's,.*UTILS_OPEN_MAX.*,#define UTILS_OPEN_MAX 1019,g' \
$(COREUTILS_DIR)/config.h
+ # This is undefined when crosscompiling...
+ perl -i -p -e 's,.*HAVE_PROC_UPTIME.*,#define HAVE_PROC_UPTIME 1,g' \
+ $(COREUTILS_DIR)/config.h
touch $(COREUTILS_DIR)/.configured
$(COREUTILS_DIR)/$(COREUTILS_BINARY): $(COREUTILS_DIR)/.configured